LinkIt7688 + breakout board output so noisy audio

Moderators: lily.li, violet, salmanfarisvp

Post Reply
okada
Pre-kindergarten
Pre-kindergarten
Posts: 2
Joined: Wed Feb 17, 2016 7:05 pm

LinkIt7688 + breakout board output so noisy audio

Post by okada » Wed Feb 17, 2016 7:16 pm

Based on Seeed Studio article ( http://www.seeedstudio.com/recipe/1076- ... -7688.html ), I am trying to develop a audio speaker with Linkit7688 + breakout board.

However, I am facing a problem that output audio have terrible noise. Do you have any idea to solve it?
We try to play sound with LinkIt7688 + its breakout board. With aplay command, the board can play .wav file but sound has terrible noise.

Conditions:
* hardware and firmware
- LinkIt Smart 7688 + Breakout for LinkIt Smart 7688
- bootloader / firmware is not changed from default
- connected speaker via 3.5mm jack
* Sound file
- Signed 16 bit Little Endian, Rate 22050 Hz, Mono
- sound file is set on LinkIt7688 local ( not streaming use case)
* command
# aplay foobar.wav

Result:
Please see attachment. You can hear the noise during audio play

We tried to change audio cable, speaker and wav file but we cannot remove the noise. Should we change software and/or hardware to play audio clearly?

shijian.fang
Staff
Staff
Posts: 8
Joined: Thu Oct 16, 2014 9:29 am

Re: LinkIt7688 + breakout board output so noisy audio

Post by shijian.fang » Sun Feb 28, 2016 1:48 am

Hi,

It seems that the on board flash has a limited speed, could you use SD card to save your music and try again?

shijian.fang
Staff
Staff
Posts: 8
Joined: Thu Oct 16, 2014 9:29 am

Re: LinkIt7688 + breakout board output so noisy audio

Post by shijian.fang » Mon Feb 29, 2016 9:50 am

Please try "aplay -M ***.wav".

okada
Pre-kindergarten
Pre-kindergarten
Posts: 2
Joined: Wed Feb 17, 2016 7:05 pm

Re: LinkIt7688 + breakout board output so noisy audio

Post by okada » Mon Feb 29, 2016 8:11 pm

Thank you for your reply!!

with -M option, it works well :D :D

Post Reply