No HDMI audio output after restart

Applications/questions using Raspberry Pi with Seeed products, please post it here.

Moderators: violet, jessie, yexiaobo

Post Reply
mail.danielbadea
Pre-kindergarten
Pre-kindergarten
Posts: 1
Joined: Wed May 09, 2018 11:18 pm

No HDMI audio output after restart

Post by mail.danielbadea » Wed May 09, 2018 11:33 pm

Hi, I have a ReSpeaker 4mic Array on my Raspberry Pi 3 Model B, running the latest version of Raspbian, connected to a TV using HDMI.

I have the ReSpeaker set up according to the instructions from http://wiki.seeedstudio.com/ReSpeaker_4 ... pberry_Pi/ and it works great.

Before I installed the ReSpeaker, I was using the TV (tv speakers) connected to the Raspberry as default audio output (sudo raspi-config>Advanced options>Audio>Force HDMI) and it was working perfectly.

After I installed the ReSpeaker my default audio is set to Analog. If I manually change the audio output to HDMI it works great (both mic and output) but after I restart the Pi, the audio output is back to Analog.

Is there a way to have my default audio output set to HDMI ? (so I won't need to set it up manually after every restart)

I reinstalled everything several times but this problem persists.

Can you please help me find a way to solve my problem and have default audio output as HDMI?

Thank you,
Daniel

hong.jiang
Staff
Staff
Posts: 200
Joined: Tue Apr 17, 2018 11:03 am

Re: No HDMI audio output after restart

Post by hong.jiang » Mon May 21, 2018 10:41 am

Hi there:
In some rare cases, it is necessary to edit config.txt to force HDMI mode (as opposed to DVI mode, which does not send sound). You can do this by editing /boot/config.txt and setting hdmi_drive=2, then rebooting for the change to take effect.
https://www.raspberrypi.org/documentati ... -config.md

Post Reply