2 Channel CAN-BUS FD for Raspberry Pi 3/4 for Ubuntu 18.0.4 armf/arm64

Applications/questions using Raspberry Pi with Seeed products, please post it here.

Moderators: lily.li, violet, salmanfarisvp

Post Reply
kylerfarrar
Pre-kindergarten
Pre-kindergarten
Posts: 1
Joined: Tue Sep 10, 2019 5:26 am

2 Channel CAN-BUS FD for Raspberry Pi 3/4 for Ubuntu 18.0.4 armf/arm64

Post by kylerfarrar » Tue Sep 10, 2019 7:46 am

Hi,

I am working with the Seeed Studio CAN-BUS FD Pi Hat for a ROS project in which we want to use a Raspberry Pi 3/Raspberry Pi 4 running ROS Melodic to control our motor controllers, IMU, etc. In order to avoid potential compatibility issues with ROS Melodic, we opted to install Ubuntu 18.0.4 Server arm64(willing to use armf if need be), however, the installer for the CAN-BUS Hat does not account for this operating environment and is thustly not compatible with the Ubuntu image. I wanted to inquire if it would be possible to get a version of the installer that works for Ubuntu, or if there are plans to release that compatibility in the near future. I would also like to bring to attention that the CAN bus DIO pin slot does not allow the male pins to stick out far enough to allow for use of the DIO pins while mounted onto the Raspberry Pi 3 or Raspberry Pi 4(this is with the nylon column spacers in place).

Please let me know if clarification or pictures are needed!

Operating System:
https://wiki.ubuntu.com/ARM/RaspberryPi - Contains download links to both the armf(arm 32bit) and arm64(arm 64bit) Raspberry Pi Images for Ubuntu Server 18.0.4

Hardware:
https://www.seeedstudio.com/2-Channel-CAN-BUS-FD-Shield-for-Raspberry-Pi-p-4072.html - Seeed Studio
https://www.raspberrypi.org/products/raspberry-pi-3-model-b-plus/ - Raspberry Pi 3+
https://www.raspberrypi.org/products/raspberry-pi-4-model-b/ - Raspberry Pi 4

Kind Regards,
Kyler Farrar

Post Reply