Change i2c address on 16 bit ADC hat

Applications/questions using Raspberry Pi with Seeed products, please post it here.

Moderators:, salmanfarisvp, violet

Post Reply
Posts: 1
Joined: Tue Jun 11, 2019 11:08 pm

Change i2c address on 16 bit ADC hat

Post by savva » Tue Jun 11, 2019 11:23 pm

I am using this hat (4-Channel_16-Bit_ADC_for_Raspberry_Pi-ADS1115) with my Raspberry Pi 3B+. I need it to be on a different i2C address other than 48. I tried soldering one of the jumpers there, but none of them would work:
soldering x49 straight up kills the Pi,
soldering x4A makes it as if every i2C address is visible,
soldering x4B kills every i2C address.
The x48 jumper remains unsoldered throughout the process. I tried the above on two different boards - neither of them worked.
I am running i2cdetect -y 1 to check for visible i2c devices on the line.

It is as if instead of changing the i2C address I just connect ground to one of the 3 lines (power, SDA, SCL).

How do I solve this? Would appreciate any help.

Posts: 735
Joined: Mon Apr 02, 2018 11:05 am

Re: Change i2c address on 16 bit ADC hat

Post by bill.yu » Fri Jun 14, 2019 5:25 pm

Hi there,

I simulated the issue, the root cause is that you do not cut the default pad connection. It is not easy to cut and you have to use the digital meter to verify if it is cut off. Then you solder the other pad, the system will work. Here is my result. thanks.


Post Reply