Change i2c address on 16 bit ADC hat


I am using this hat (4-Channel_16-Bit_ADC_for_Raspberry_Pi-ADS1115) with my Raspberry Pi 3B+. I need it to be on a different i2C address other than 48. I tried soldering one of the jumpers there, but none of them would work:

soldering x49 straight up kills the Pi,

soldering x4A makes it as if every i2C address is visible,

soldering x4B kills every i2C address.

The x48 jumper remains unsoldered throughout the process. I tried the above on two different boards - neither of them worked.

I am running i2cdetect -y 1 to check for visible i2c devices on the line.

It is as if instead of changing the i2C address I just connect ground to one of the 3 lines (power, SDA, SCL).

How do I solve this? Would appreciate any help.

Hi there,

I simulated the issue, the root cause is that you do not cut the default pad connection. It is not easy to cut and you have to use the digital meter to verify if it is cut off. Then you solder the other pad, the system will work. Here is my result. thanks.

1 Like


Thank you for this post, it made me discover the same issue I have using a grove mounted ADS1115.

A connection very difficult to see and below the paint betweenthe two 0x48 labelled pins on the back of the unit !

Must still figure out how to cut and do the fine soldering on the other pins.

These kind of things could be better documented…