Shield bot right motor issue

Ardiuno Compatible shields

Moderators: lily.li, violet, salmanfarisvp

Post Reply
danieldzyuba
Pre-kindergarten
Pre-kindergarten
Posts: 2
Joined: Thu Jun 27, 2019 2:55 am

Shield bot right motor issue

Post by danieldzyuba » Thu Jun 27, 2019 2:56 am

Hi I have a pretty old shield bot (2012) and my right motor doesn't work; I can power it from a 5V source and if I turn it it will give power to the arduino, I tested continuity and it's fully connected to the servo driver chip. I tried with a seeduino but it will still not work
Have any idea ?

PS: I'm new to arduino and coding so please don't use too complex language, thank :D

bill.yu
Junior-7
Junior-7
Posts: 735
Joined: Mon Apr 02, 2018 11:05 am

Re: Shield bot right motor issue

Post by bill.yu » Thu Jun 27, 2019 11:19 am

Hi there~,

1. you can use the 1.5 battery and connect it to motor 2 pads directly to check if the motor moves. If it does not move, the motor maybe bad. If it moves, it will be related with seeeduino code.

2. You can follow http://wiki.seeedstudio.com/Shield_Bot_ ... ng-started to burn the code.

3. I record a video about the example. thanks.

https://github.com/SeeedDocument/forum_ ... eldBot.mp4

danieldzyuba
Pre-kindergarten
Pre-kindergarten
Posts: 2
Joined: Thu Jun 27, 2019 2:55 am

Re: Shield bot right motor issue

Post by danieldzyuba » Thu Jun 27, 2019 7:04 pm

Thanks for responding, I tried to power the motor with 5V and it works, I also tried to write my own code but it still doesn't work.

bill.yu
Junior-7
Junior-7
Posts: 735
Joined: Mon Apr 02, 2018 11:05 am

Re: Shield bot right motor issue

Post by bill.yu » Mon Jul 01, 2019 2:05 pm

Hi there~

1. If you burn the below code to shield bot, both of the motors shall rotate.

http://wiki.seeedstudio.com/Shield_Bot_ ... ng-started

2. If it does not rotate, the shield bot may be bad from hardware point of view. The motor is connected with L298 and then controlled by arduino through IN1/IN2/IN3/IN4 and ENA/ENB. We suspect the L298 is dead. thanks.

Image

Post Reply