Grove NFC v1.1 does not work with UART

Grove is a modulated, ready-to-use tool set.
Much like Lego, it takes a building block approach to assembling electronics.

Moderators: lily.li, violet, jeremy882, crail.lyu969

ryoku12345
Pre-kindergarten
Pre-kindergarten
Posts: 6
Joined: Wed Jul 10, 2019 2:57 pm

Re: Grove NFC v1.1 does not work with UART

Post by ryoku12345 » Tue Aug 06, 2019 2:31 pm

bill.yu wrote:
Fri Aug 02, 2019 4:37 pm
Hi ~, We see the same issue and we are looking @ the issue and keep you posted. thanks.
Hi there,

thanks for investigating this issue. I will wait for any news regarding this problem.

testpresta2
Pre-kindergarten
Pre-kindergarten
Posts: 5
Joined: Thu Aug 01, 2019 5:45 pm

Re: Grove NFC v1.1 does not work with UART

Post by testpresta2 » Wed Aug 07, 2019 7:58 pm

Thanks for your answer.

Why your library and your screenshots shows a PN532_SPI folder (and your sample programs) if your board cannot manage it ? I wasted a lot of time.

I am working with an Arduino Mega and a Grove Shield (i have tried the 2 shields: base and mega). It is impossible to make for the i2c connection.

Should i work with Wire or Wire1 (TwoWire) ?

Thanks

testpresta2
Pre-kindergarten
Pre-kindergarten
Posts: 5
Joined: Thu Aug 01, 2019 5:45 pm

Re: Grove NFC v1.1 does not work with UART

Post by testpresta2 » Wed Aug 07, 2019 8:08 pm

I am sorry but i do not understand anything.

If i want to work with i2c, i have to sold TP3 to SDA, TP2 to SCL, P1 to I2C.
The documentation says i have to "cut" connexions to TX, RX and UART. But i cannot see them.

Thanks

ryoku12345
Pre-kindergarten
Pre-kindergarten
Posts: 6
Joined: Wed Jul 10, 2019 2:57 pm

Re: Grove NFC v1.1 does not work with UART

Post by ryoku12345 » Mon Aug 12, 2019 2:54 pm

testpresta2 wrote:
Wed Aug 07, 2019 8:08 pm
I am sorry but i do not understand anything.

If i want to work with i2c, i have to sold TP3 to SDA, TP2 to SCL, P1 to I2C.
The documentation says i have to "cut" connexions to TX, RX and UART. But i cannot see them.

Thanks
Hi,

the connections are on the PCB. You can use a knife to cut the connection between P1 and Uart.
After that check the connection between P1 and Uart with a multimeter.
I did use the Grove NFC v1.1 module with I2C. At first it did not work. After switching SDA and SCL on my Arduino it worked.
I do not know if it is supposed to be that way, but I was glad it worked after that.

testpresta2
Pre-kindergarten
Pre-kindergarten
Posts: 5
Joined: Thu Aug 01, 2019 5:45 pm

Re: Grove NFC v1.1 does not work with UART

Post by testpresta2 » Mon Aug 12, 2019 9:33 pm

Thanks very much for your help.

I cannot see any connexion between UART and P1. Look: This is a fresh and new Grove NFC 1.1 module:

Image

There are no connexion between UART and P1...

Can we have an official answer from seeed about this SDA and SCL inversion ?

Thanks

ryoku12345
Pre-kindergarten
Pre-kindergarten
Posts: 6
Joined: Wed Jul 10, 2019 2:57 pm

Re: Grove NFC v1.1 does not work with UART

Post by ryoku12345 » Mon Aug 12, 2019 10:24 pm

Hi there,
the connection between P1 and UART is on the PCB. Bill.yu has posted the schematic of the module (05 Aug 2019 15:41). There u can see the connection between the two pads. I edited your picture for clarification.

Image

Post Reply