Seeeduino LoRaWan update to 1.5.6 : LoRaWan library missing

Arduino, Seeeduino Serials and mutants. Share your problems and experence on arduino compatible board such as seeeduino/stalker, etc.

Moderators: lily.li, salmanfarisvp, violet

Post Reply
dave624
Pre-kindergarten
Pre-kindergarten
Posts: 6
Joined: Sat Jul 13, 2019 4:01 am

Seeeduino LoRaWan update to 1.5.6 : LoRaWan library missing

Post by dave624 » Fri Nov 01, 2019 12:38 am

Hi, I just followed a prompt from Arduino 1.8.10 IDE to update board support for Seeeduino LoRaWan to 1.5.6 => now I get build errors e.g."LoRaWan.h not found". The LoRaWan library is not there. Reverting to 1.3.0 cures this; installing 1.5.6 rather than updating gives same problem.

Has some major change happened in the move from 1.3.x to 1.5.x that I need to act upon?

Please advise, Dave.

haresfur
Pre-kindergarten
Pre-kindergarten
Posts: 7
Joined: Sat Sep 28, 2019 5:29 pm

Re: Seeeduino LoRaWan update to 1.5.6 : LoRaWan library missing

Post by haresfur » Thu Nov 14, 2019 6:59 am

Yes, I needed to revert to 1.3 library. I think there was another post indicating a similar problem

seeedstudio.com168
Pre-kindergarten
Pre-kindergarten
Posts: 1
Joined: Sun Nov 17, 2019 7:15 pm

Re: Seeeduino LoRaWan update to 1.5.6 : LoRaWan library missing

Post by seeedstudio.com168 » Sun Nov 17, 2019 7:19 pm

Yes, I experienced the same problem.
It seems that the whole LoRaWAN directory is missing in version 1.5.6.
I can confirm that a downgrade to version 1.3.0 can be used as a work-around for the problem

dave624
Pre-kindergarten
Pre-kindergarten
Posts: 6
Joined: Sat Jul 13, 2019 4:01 am

Re: Seeeduino LoRaWan update to 1.5.6 : LoRaWan library missing

Post by dave624 » Fri Jan 31, 2020 12:43 am

For anyone that's been held-up by this, I just updated to 1.6.1 and find my code compiles and runs ok with this (latest) board support. Thanks to whoever took this on and fixed it.

Dave.

dave624
Pre-kindergarten
Pre-kindergarten
Posts: 6
Joined: Sat Jul 13, 2019 4:01 am

Re: Seeeduino LoRaWan update to 1.5.6 : LoRaWan library missing

Post by dave624 » Tue Feb 11, 2020 4:44 pm

...and it seems I spoke too soon. With 1.6.6 (latest) SAMD board support, I'm seeing anomalies like: -
  • ADC values higher than 1.3.0 build, e.g. full-charge LiPo battery voltage now reads 4.7v, previously 4.15v;
  • Power consumption ~2x higher than 1.3.0 build, e.g. my app now lasts 9hr on its battery; previously 24hr.
Not happy! I'm wondering whether I should just stick with 1.3.0 to finish proving my app, then port to another platform that has better board support... e.g. regression testing would be nice, release note would be nice.

Dave.

haresfur
Pre-kindergarten
Pre-kindergarten
Posts: 7
Joined: Sat Sep 28, 2019 5:29 pm

Re: Seeeduino LoRaWan update to 1.5.6 : LoRaWan library missing

Post by haresfur » Fri Feb 14, 2020 11:58 am

dave624 wrote:
Tue Feb 11, 2020 4:44 pm
...and it seems I spoke too soon. With 1.6.6 (latest) SAMD board support, I'm seeing anomalies like: -
  • ADC values higher than 1.3.0 build, e.g. full-charge LiPo battery voltage now reads 4.7v, previously 4.15v;
  • Power consumption ~2x higher than 1.3.0 build, e.g. my app now lasts 9hr on its battery; previously 24hr.
Not happy! I'm wondering whether I should just stick with 1.3.0 to finish proving my app, then port to another platform that has better board support... e.g. regression testing would be nice, release note would be nice.

Dave.
Do you know which ADC values are correct? Have you measured the LiPo voltage with a multimeter at the same time?

Post Reply