XIAO nRF52840 Boot from External Power Supply

I am trying to power a Xiao nRF52840 with an external power source and am trying to connect to the vusb terminal but am only getting intermittent booting, am I supposed to be able to power from the vusb terminal with a 5 volt supply (usb charger) or do I need to connect to only the battery terminal?
I have one that seems to boot fine from the vusb and 1 that will intermittently boot to it and 2 that will not boot to it so I am unsure what the problem is.

Hi Kevin_Jones,
I have a few questions to help you solve the problem.

  1. What kind of things are connected to XIAO? (e.g. sensors, batteries, etc.)
  2. Please tell us exactly what you mean by “boot fine”, " intermittently boot", or “not boot”.
  3. Is there a “while(!Serial)” in your sketch?
  4. In my USB charger, if the charging current (in this case, the current consumption of XIAO) is low, the charging is considered to be finished and the output is turned off. Have you tried with a different power supply?

Is the green LED on during battery charging?

Hello msfujino,
Thanks for getting back to me with these great suggestions, I actually have it mounted on a pcb with a 5v 2A power block. And yes I do have the while (!Serial) removed (that one has bit me many times). It turned out it was a defective xiao, my replacements arrived today and as soon as I replace it, it worked fine.
Thank You.