Xiao not programming

i face the same problem. It works on my laptop but not on my desktop. It gets stuck in the exact same point as yours. I tried to tinker around it and now my XIAO is bricked :frowning: . its no longer detected by any computer., it doesnt goto bootloader mode, it doesnt reset with the jumper method, only a green led glows… nothing else happens…its bricked :frowning:

Anyone has any experience reviving a dead xiao?

i was able to unbrick mine…using raspberry pi

I ran in to the same problem, and to me it appears to be baud rate related. I can program at 9600 baud over and over again, but the symptom occurs repeatedly when I try to program the XIAO at a higher baud rate. This occurred on 2 different modules. Now I will try increasing speed slowly instead of jumping immediately to 115200 baud and see how fast I can reliably program the XIAO with my setup.

I ran in to the same problem
-baud rate is 9600
-default drivers from Microsoft in Windows10
-uninstalled all ghost COM ports
-USB Intel ICH9
-Arduino: 1.8.13 (Windows Store 1.8.42.0) (Windows 10), Board: “Seeeduino XIAO, Arduino, Off”
BN: Seeeduino XIAO VID: 2886 PID: 802F SN: 461E97315053574C342E3120FF0C021B


:confused:

I see a lot of similar serial ports on your computer that might interfere with downloading. @MichaelZP

on another computer this Seeeduino XIAO is programmable :confused:

I have two Raspberrypi’s that are 3B and tried this from this page: How to unbrick a dead xiao using raspberry pi [ GUIDE ][openocd]
and it didn’t work. When the first one didn’t work, thought it might be dead, so I tried it with a known good one…now I have two bricks. Wondering it the openocd software changed from when did it and broke it?

Hi @tannenba

Please try the above method as mentioned in a previous post

I actually did and was able to bring one of them back. I still have a dead one. I think it is really dead.

@tannenba Oh. Maybe you could try one last method for the dead XIAO you have, which is to enter the bootloader mode or to reset it.

Best Regards,
Lakshantha

Tried that, no go it’s dead. Thanks for the suggestion.

1 Like

Just got one of the Seeeduino developemnet boards and it has pogo connectors for the 4 pins on the bottom. Works great with the ST-Link.

2 Likes

Got the same problem, after few days flashing without bigger problems, now is freezed,
Blue and greeb led constant on, amber quick flash 3 times, try to reset it or reloaded number of times.
Still unable to upload any sketch even empty. there is comunication with it, you can check board info, serial etc. but no chance to upload any data.

After numbers of try got it working, with double tap reset, then change com port in arduino and reload sketch

1 Like

You are likely using Windows

If you are having any of these issues

**Uploads forever then fails *
**Upload bar disappears **
*Won’t compile even though there are no errors
*XIAO does not receive reset signal

*If you have a program that has ran in the past but when you try to upload it now your Seeeduino acts like it dont want to accept that shit and the ide shoots out a weird ass compiling/upload message that you cant understand

*other COM issues

PLEASE TRY THIS PROCEDURE

1. Go to Arduino IDE app settings and this can be done by right clicking the arduino app in start menu or whatever directory it is located on your computer.

2.There will be 3 options, you will use all of them.1 Terminate, 2 Repair, then 3 Reset; none of these will delete your precious data .

3. Restart your computer and then bring the Arduino IDE up if you don’t get the common message that your libraries have been updated select manage libraries through the tools tab (this will update your list of libraries automatically) don’t expect it to pop up right away, just be patient (you don’t really have to do much after this) soon you will see a sluggish loading bar at the bottom of you library manager that will fill to 100%. After that process is finished, you should restart the IDE and try to compile and upload your program assuming you are on the correct COM and you have already did the prerequisites for Seeeduino XIAO setup.

Your program should upload successfully, you are welcome !

I am having more or less the same problem @Seeed. May be a fix of the firmware or so is in order… They brick very easy now…

Firstly let me say I am a firmware engineer of 20+ years. My initial impressions of trying to flash the XIAO are not good, I have no problems flashing other microcontrollers using Arduino Studio. The XIAO came preprogrammed with the 1 second blink sketch (solid green LED and 1Hz flashing yellow LED). I modified the sketch to blink at 5 seconds and tried to upload it, it compiled slowly and then sat there for about 5 minutes saying “uploading…” and then failed giving me the message

Arduino: 1.8.13 (Windows 10), Board: “Seeeduino XIAO, Arduino, Off”
Sketch uses 34108 bytes (13%) of program storage space. Maximum is 262144 bytes.
An error occurred while uploading the sketch

I checked my COM ports and all was good. It was shown in Windows 10 to be on COM14. After verifying ports, I swapped COM ports and swapped out cables. An hour later nothing. It really shouldn’t be that hard.

I read a post and double tapped the RST and immediately noticed my COM14 port disappear and COM15 appeared. The green LED was still solid but the yellow LED faded in and out. I tried to flash it again and it seemed to have flashed correctly. My COM15 port vanished an COM14 port came back? this is not what I have seen online, people just seem to plug it in and flash it without double resetting and messing with COM ports.

I thought this was bootload mode not download mode?

Just to let people know I fixed my own issue by installing the Circuit Python bootloader.

Does that bootloader handle Arduino type uploads too? I’m not interested in Python but the uploading problems on this device are absolutely infuriating. Clearly some timing issue as sometimes the 1st upload fails, other times the 3rd sometimes the 4th and then the 1st again. Happens with every single one of the three I purchased. The reset workaround is entirely too tedious for iteratively uploading.

Using Mac OSX Big Sur and PlatformIO with VS Code.