Xiao Esp32S3: VSCode vs Arduino IDE

Hello All,
First, I love the Xiao ESP32S3. I have used both the sense version and basic version. I have had plenty of success with it. That said, I have two cases with it that are confusing.

I will not post details, code or hardware specifics as these things would just clutter up my question.

Confusion 1: I used the sense version to create a 10 camera array that takes pictures at 3 second intervals. It works great. However, I started the project coding in VSCode, and could not get the autofocus to work. At some point I just tried the exact same code, libraries and hardware using the Arduino IDE, the autofocus worked perfectly?

Confusion2: I used a basic version to utilize an MS5837 pressure sensor. I could not get the sensor to work. From the prior experience as a random hail Mary pass, I copied the code into the Arduino IDE and imported the exact same libraries. In the Arduino IDE the code and sensor worked perfectly?

In both cases, I am using the same code, same libraries, and same hardware on the same day. The Arduino IDE works and VSCode does not? I have done multiple other projects that work fine in VSCode using these Xiao boards?

Does anyone else have similar experiences? Any solutions would be appreciated.

Hi there,
Hmm must the old between the keyboard and floor bug? :stuck_out_tongue:
So if you would post the verbose compiler output of both environments, It would be easier to see what is going on down low. My hunch would be a couple?

  1. Are you selecting USE arduino LIBs in opening or the project in PLIO? or NOT using PlatformIO?
  2. The Platform.INI what BSP are you using , is it different than the other?
    Sounds to me in general the BSP’s are different and the corresponding PINS or Variant’s may be also different. without seeing anything no empirical data to work with just USER experiences responses is all you’ll get.
    GL :slight_smile: PJ :v:

what BSP are you using in the good /working enviro on Arduino. Is it the Beta ESP32?, 2.1.1?

Thanks PJ!!!

Seems like the BSP should be the culprit. And, your suggestion of looking at the verbose compiler output is perfect as well. I’ll be investigating this week.

thanks again,

1 Like