XIAO ESP32C3 uploading new sketch, manual setting to bootload mode?

Hello, I am new with 2 XIAO ESP32C3 boards. I have set my environment and successfuly managed to upload the first “hello world” prog. However when uploading new version. I always have to put XIAO bootloader mode (holding boot down and pressing reset) after upload additional reset of the board is needed to get it running.
Is there a way to avoid this manual setting, like developing other boards like Arduino ?
The com port is visible and the serial monitor is working. All the getting started tutorials do not mention this additional manual operation during upload. I have tested this using both Arduino IDE and PlatformIO, using esptool upload protocol. No serial monitor is connected and no GPIOs are connected.

This does not sound normal, you can try to re-flash the firmware according to the steps here.

Many thanks, I reflashed firmware version Feb 7 2021 and now it works as expected !

Hey can you explain exactly how you did it? I have also reflashed the bootloader according to the wiki, but got exactly the same result (Holding down the boot button startup and pressing reset after uploading).
Mabye its the version since feb 7 is not available anymore. How did you get that version?

Hi Steven
I am on journey now, but return next week. I will explain it then if you cannot fix it before!

Thank you, I will keep trying👍

I reflashed per those instructions. No joy.

Following the istructions I reflashed the firmware, and then it started to work normally (no boot+reset buttons needed during upload. When reflashed the ESP32-C3 reports firmware:
Build:Feb 7 2021
Saved PC:0x42039572
But I am little confused,because I choose bin:
This should be version Oct 14 2021 ?
Anyway it works now. Are you sure that the ESPTool reported successfull flash ?

1 Like

I fixed the issue. I have created a repository with a guide on how to do it. Please contribute if necessary. I created it in a way that other board fixes can be addressed in this repo aswell.