XIAO esp32c3 stopped printing rom boot messages

XIAO esp32c3 (and esp32s3 for that matter) stopped printing boot messages it always used to print before. I am not sure at which point it happened. But even devices that I did not reflash for long time or right out of the factory stopped printing them.

Everything else seems to work well - I can flash my binary and it works ok, it can print messages to Serial through USB to Arduino Serial Monitor. The device enters boot mode on boot (D9) button - but silently - with no messages printed.

The messages I am talking about similar to:

Build:Feb 7 2021
rst:0x1 (POWERON),boot:0xc (SPI_FAST_FLASH_BOOT)
mode:DIO, clock div:1
entry 0x403cc710

Tried pulling GPIO9 (XIAO D9), GPIO8 (XIAO D8) and GPIO2 (XIAO D0) high with resistors, I see values change in GPIO_STRAP_REG, but it has no effect on rom boot messages - they just don’t print.

Any ideas appreciated.

Hi there,
Check your tools menu for the device the debugging level…
GL :slight_smile: PJ

check these,


Hi PJ_Glasso, thank you for ideas.
Still unsolved.
Changed debug level from None to Verbose - no effect on rom boot messages printing.

This seem to related only to s3, RTC_CNTL_STORE4_REG register does not exist in c3.

This one talks about eFuse print control and all my devices have USB printing enabled (default):

Usb fuses:
DIS_USB_SERIAL_JTAG_ROM_PRINT (BLOCK0) USB printing = Enable R/W (0b0)

The weird part that rom boot messages are gone even for fresh-from-the factory XIAO esp32c3, with default firmware - output looks like:

So whole thing seems to my environment related issue, not the XIAO device itself.

Hi There,
It must be something in the DEV enviro, or USB cable maybe?
What’s your setup ?
Can be the flash tool too , turning off the API Permanently disable logging (BOOT_ROM_LOG_ALWAYS_OFF)
GL :slight_smile: PJ

Not sure where to start… Windows 10 Thinkpad notebook. Arduino IDE 2.3.2. Espressif esp32 2.0.14 boards library installed.
Espressif IDF 5.2 installed, but it shouldn’t matter, should it?
Tried different USB cables/ports/USB hubs.
This seem to have effect only on XIAO USB devices with embedded USB/JTAG port. Espressif esp32c3-DevKit works fine - rom messages are printed normally. It has cp210x UART-to-USB bridge, that seems to be the difference.