XIAO ESP32C3 - GPS Module

Hello all,

I normally use a Arduino NANO. I connected the GPS module to the UNO and was able to read the serial output no problem.

When I hook it up to the ESP32C3 I cannot for life of me figure out how to read the GPS data. I’ve tried using regular digital pins then setting up a software serial. Then I read the pin out by using the Pin 6,7 as RX, TX. I cannot find any documentation to figure out how to achieve this. Does anyone have any information on how I can do this?

Basically I just want to connect the RX, TX of the GPS module to the ESP32C3 and read the GPS strings via the serial monitor. I’ve been beating my head against the wall. Any information would be helpful.

Hello, which GPS sensor are you using?

Hi, I faced the same problem. Stress. It is for school project and due this week. I used GT-U7 GPS module, and ESP32-C3. Your help very much appreciated.Thank you

Have you tried this one? ESP32 / Google Maps - GPS Co-ords to Postal Address - Hackster.io
It features the GPS module that you’re using.

Please check this guide, you need to set USB CDC On Boot to Disabled in arduino ide .

I want to do the same thing with you, but I found from the wiki, it is not described very clear about multi-uart usage.

The wiki is not very useful for this issue.

Sorry for the bad experience. Regarding the XIAO course resources, we now have dedicated colleagues working on this course, but the course is still mainly aimed at more basic use. In many cases we would encourage users to refer to existing basic usage for more in-depth secondary development.
But we will improve our wiki and course content based on your suggestions. Thank you for your understanding and advice on our work and we wish you a happy life.

I’m also having a problem reading gps (ATGM336H) data on the XIAO ESP32C3. Is there someone that can help or point me in the right direction?

I found my problem. I’m now using HardwareSerial instead of SoftwareSerial.

HardwareSerial hs(0);

hs.begin(9600, SERIAL_8N1, -1, -1);

The “-1” means to use the default (in this case, pins 6 and 7)

I’m now reading GPS data!!!