XIAO cannot upload to it's port

Hello, I have a new esp32s3 board. In Linux, it registers a port as TTYACMO, but I cannot upload code with Arduino Studio. The error response is “No device found on ttyACM0.” Now I’ve tried resetting to bootloader multiple times, but to no avail. I have the XIAO mounted on the XIAO expansion board.

After lots of searching online, it seems like this is a common problem, and I’ve not had any luck getting it to work. Thanks.

i just saw this today… check and make sure no pins are contacting the spring loaded pins under the xiao… those pins were designed with the SAMD in mind and may cause a problem… i assume it works fine when not connected to the expansion board try placing a sticker or piece of tape on the bottom of the XIAO

Thanks for the response. I put the Xiao on a breadboard and did a bootloader and reset. The Xiao is seen by Linux as USB device ttyACM0, neither the Arduino IDE or PlatformIO can write to it, and it returns “No device found on ttyACM0.”

Hi there,
Have you tried , The Unplug USB, HOLD reset button while inserting USB Technique?
Try that. first.
Does the Windows machine see and re-enumerate it again?
I had one unit that I had to Press the reset several times, while holding the boot button down.
Finally after about 40 try’s it Bonked and was there… Com23
I think the switch was dirty or full of solder paste I just squeezed it out by mashing it so many times I surmise, They may need better cleaning after the soldering or it had too much paste initially.
Unit works now without issue… and without setting boot mode, just uploads… and Go’s.
GL :slight_smile: PJ