X86J4105 with EM06-A doesn't read SIM

I have tried two SIM cards that work OK in phones, and can’t seem to get the EM06-A to acknowledge that a SIM card is inserted. My ODYSSEY is one that came with Windows 10 installed in the eMMC. I have also installed three antennas I obtained from Amazon (https://www.amazon.com/gp/product/B077X9YJVP/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1) that were mentioned elsewhere in the forum. Shouldn’t antennas have come with the EM06-A?

Of note: The instructions for installing the EM06-A in the Wiki under Windows 10 just doesn’t work as shown. I did find the Windows 10 driver on the Wiki and install it. It gave me all the devices in the Device Manager as expected. There is no installation dialog as shown in the Wiki. I do not get a Cellular Network icon in the Network Settings. I can talk to the cellular modem through COM11, and used AT commands to query for the SIM card and it says there is no SIM card inserted.

Is the SIM card properly inserted in the lower slot? I paid attention to the marking on the board as to where the notch should be.

So, I’m stuck with no cellular networking and what seems like a cellular modem that can’t see my SIM card.

Do I need a SIM card for the driver installer to create the Cellular Networking icon? Do I need antennas and a cell signal to get it to install fully? What do I need to do to get it to recognize either SIM card I’ve tried?

So you have installed anntenna and the 4G module and SIM card does not work? Can you tell me what your 4G module is?

Also does it have a driver appeared under your device manager in windows?

Sorry for the issue caused.


In the picture and my writing, the 4G module is the Quectel EM06-A I purchased from Seeed because of its compatibility with the X86J4105. This X86J4105 came with Windows 10 installed. As I said, all of the devices I should be seeing in Device Manager are there. There is no error reported. In the Networking section of the Control Panel, I can see the Cellular modem trying to initialize itself. Every 10 seconds or so, it will try to initialize and fails. There is no actual error reported; it just keeps trying to start.

Despite that, I can use Putty to connect to the cellular modem and interact with it using AT commands. I can see that the cellular modem is saying it doesn’t see the SIM card. It tells me it’s an EM06-A and otherwise will report various things. It seems to be the driver isn’t right. Also, Microsoft updated the installed Windows 10 to build 2004, which is relatively new and comprehensive. Windows 10 is working well otherwise.

One question I have: when you look at the picture of my SIM card plugged in, does it look correct as far as how far it goes into the socket. When I put in an SD card into the upper socket, it goes in much farther. This may be normal - I don’t know. Is it normal?


Hi can i also know your SIM card’s Operator? Antennas installed correctly also?

The two SIM cards I’ve tried are both T-Mobile, though different plans. I believe I now have the antennas installed correctly because I’m getting a good signal report from the EM06-A. Here is part of the log of my interactions with the EM06-A:


+COPS: (1,“312 530”,“312 530”,“312530”,7),(1,“311 882”,“311 882”,“311882”,7),(1,“Verizon”,“Verizon”,“311480”,7),(1,“311 490”,“311 490”,“311490”,7),(1,“Sprint”,“Sprint”,“310120”,7),(1,“T-Mobile”,“T-Mobile”,“310260”,7),(0-4),(0-2)


+CSQ: 23,99




As you can see, the EM06-A is seeing at least one T-Mobile cell tower with a reasonable signal level. What we also see is that it is not recognizing that a SIM card is inserted into the slot.


  1. From the pictures in my previous messages, does the SIM card appear to be properly inserted?

By the way, I have set up my ODYSSEY to dual-boot the original installed Windows 10 and Ubuntu 20.04.1. There is no difference in the way the EM06-A behaves with either system.

So I now have a working system with cellular data as I wanted. The way I fixed was to replace the X86J4105 and the EM06-A with new ones. I used the same SIM card I had been struggling with. I just activated Windows 10 Pro, then installed the new EM06-A with three new antennas and powered it up. Windows 10 recognized the EM06-A immediately and installed it. The Network Setting shows I have T-Mobile cellular data. I did not have to manually install any software or make any settings. It figured it out and did it right. The Wiki is outdated and misleading. It’s obvious to me that my original system had a serious defect. It’s either the original EM06-A or the original X86J4105. I will be figuring that out later. Right now I’m updating Windows 10 and will be installing Ubuntu on the NVMe drive I have for it so I can dual boot Windows 10 and Ubuntu.

Now I have more strangeness to report. I no longer have cellular internet in Windows 10. I made the mistake of installing the Windows USB drivers for the EM06-A. That was a big mistake. It enabled the various USB serial ports and gave the cellular modem its real name, and killed the connection to T-Mobile. Uninstalling the drivers didn’t fix it, though it did put back the cellular modem name and removed the serials ports as I expected.

I then installed a new NVMe SSD and installed Ubuntu 20.04. I now have cellular internet, but only in Ubuntu. Ubuntu has all the drivers for the USB serial ports as well as the EM06-A cellular modem, unlike Windowss 10. This says that the new hardware is good.

I will need to investigate the original hardware to see if I can get it working.

Right now I’d say the Windows USB driver for the EM06-A breaks the cellular internet access.

I was able to restore cellular data in Windows 10 by doing what I call a cold reset. That means to remove all power, including the RTC battery and wait a minute or two. I now have cellular data back in Windows 10 and still have it in Ubuntu 20 as well.

I tried uninstalling the EM06-A USB drivers in Windows 10 on the original faulty system. With my T-Mobile SIM card plugged in it was still saying it couldn’t see the SIM card. More trouble shooting to come later.

So I spent the morning swapping around cellular modems, motherboards, and SIM cards. The bottom line is that the original X86J4105 and EM06-A I’ve been struggling with for weeks are simply defective when it comes to the cellular modem’s proper functioning with the SIM card and motherboard. I was surprised when I put the new known-good EM06-A on the original X86J4105, and it didn’t work properly. It was just like the original one. The next surprise was when I put the original EM06-A on the new X86J4105, and it didn’t work either. WHAT!

Only the new X86J4105 and EM06-A work properly and completely. This is all with my trusty old T-Mobile SIM card. This includes Windows 10 Pro and Ubuntu 20.04. It also includes not installing the Windows USB drivers because that really messes it up.

We have encountered SIM CARDS that have been pruned, resulting in incorrect identification. @CrunchyDoodle

I don’t see how that’s relevant here. This T-Mobile SIM card works perfectly with my new X86J4105 and EM06-A in both Windows 10 (no USB drivers) and Ubuntu 20.04. It’s only a problem with my original X86J4105 and EM06-A that I purchased earlier.

Are you saying that somehow my SIM card is being misidentified by one particular X86J4105 / EM06-A combination and not another? And further, that this misidentification manifests as No SIM Card Inserted, which is a low-level hardware function that senses a SIM card present with two pins being connected by the SIM card? I don’t buy that premise.

Hi @CrunchyDoodle

Please can you try to try this:

  1. Install the OS onto a Hard drive SSD or HDD, but not eMMC on the new and working Odyssey x86. Connect the new 4G module and see if it’s working properly

  2. If it’s working properly, plug this Hard drive that contains this OS to the original x86 and plug the new 4G module and see if it works. (Checking the old x86)

This also seems strange to us, would be very helpful if you can help us narrow down the bugs.

Sorry for any issue caused

Best Regards,

I can do that tomorrow. I have Ubuntu 20.04 installed on an NVME SSD in the new working system. It would be easy enough to swap it into the original X86J4105 and try it with both EM06-A modules. I could also install my own Windows 10 on another NVME SSD and try that too. I’ll report back tomorrow.

I spent the morning and some of my afternoon experimenting with installing Ubuntu and Windows on an NVMe SSD and checking out how my original X86J4105 and EM06-A reacted versus the newer examples I now have. When installing Windows 10 (build 2004 September), I didn’t need to finish. During the networking search, Windows 10 saw the cellular modem and reported the SIM card was missing on the original system with the newer EM06-A and the SIM was there. It was the same with Ubuntu.

I appreciate the issue of both the original X86J4105 and EM06-A being defective is unusual, though not unprecedented. I have been working with IBM-PC compatible hardware and software since 1982, when I designed and built an 8-channel multi-protocol serial communication card for the IBM-PC. I have designed and built dozens of embedded computers and adapter cards since, and I’m sure this original X86J4105 and EM06-A came to me defective.

I am fairly happy with the newer X86J4105 and EM06-A I have working so well. I took this outfit on a field trip yesterday, where I powered it with an OmniCharge power brick set to 12VDC, along with my Sculptor 4K DP-over-USB monitor. It worked flawlessly.

This is good news, please let us know if you have any feedback. @CrunchyDoodle

I am currently dealing with similar issues. Could you recommend which antennas to purchase for the cellular reception?

4G and 5G.

Thank you.

I quote from the first message in this thread:

Can you take a picture only at the socket for the card? There may be a problem with the card. Have you tried another SIM card to put?

If you follow the full thread from the first posting, you will see the pictures you are asking about and the solution to the issue. I now have a full working system that has reliable cellular internet using the original T-Mobile SIM card. It was bad hardware and some bad software.

Any suggestion about Odyssey?