WM1302 PI HAT no available GPS coordinates available yet

Hi,

A WM1302 gateway has been installed on a Raspberry Pi using a WM1302 PI Hat. After the Lorawan software installation all seems to be working except the GPS (did direct the GPS to a clear sky south - but don’t believe that was the issue). I checked the (GPS) UART pin 8 (RxD) and pin 10 (TxD) on the interface with an oscilloscope.
The TxD seems to have a signal and a decoder can make sense out of it. However there seems to be no (proper) signal on the RxD.

Anybody any suggestion on what might be the root cause? Any driver issue or something with the hardware?

Regards, René

Hi, have you tried your setup outdoor?

Hi, Yes I did test outdoors with a clear sky view to the south and for a couple of hours.
Just to add. I tested with another Raspberry Pi and another WM1302 PI Hat. All the same result. Seems not the hardware.

If you think it’s a bad HAT, you’d better mail to seeedstudio’s customer care with your invoice number. You may get a replacement if the warranty is still valid.