Wiznet Ethernet shield - w5100

Hello and thanks for reading.

I’m a newbie of Seeeduino, so maybe my next question has been answered somewhere else or there could be some docs available which I didn’t find.

I just got some new Seeeduino Mega 1.21 and some Wiznet w5100; replaced the spi.h file, downloaded EtherDHCP library, tested the DHCP lease and everything was perfect !!!

In my project I also have to use some PWM signals; which signals are actually used by the Wiznet shield ? It mounts on top of Seeeduino getting signals from both already-soldered connectors (power, analog in 0 to 7, rx0, tx0, PWM 2 to 13, GND, AREF), but probably just to allow accessibility to those.

Many thanks in advance for Your kind support.


Arduino uses digital pins 10, 11, 12, and 13 (SPI) to communicate with the W5100 on the ethernet shield. These pins cannot be used for general i/o.

please take a look at this page

Many thanks Constantine !

Hi, I have been using Seeeduino for a while but am new to connecting it to the internet with the Ethernet Shield.

I have been trying to connect the device to the internet for a few days now to no avail. I have tried both the Client() and Server() examples and tinkered with the ip, gateway, subnet etc. with all value I could possibly come up with. No success. I have also tried the EthernetDHCP and EthernetDNS library neither of them worked for me (just kept loading . . . . . . . . . . . . . )

I tried Pinging the IP (I tried many different ones) I gave the seeeduino but that only ends in timeouts.

Here’s my (very basic) set up:

The version of my Ethernet shield

The version of my Seeeduino

The router is a Huawei B970.
Connecting a laptop (mbp) to the router directly (via Cat5 cable) would allow it to connect to the internet immediately.

It seems that a lot of people were able to get through this stage without much trouble. I am out of ideas now… and desperate to make this work. Please help.

Thanks in advance.


p.s. I would like to be able to do sth like this:
blogdoje.com.br/2010/04/11/teste … seeeduino/
and then start using Pachube etc.

Hi Joe,
I’m sorry, you have the older version Ethernet Shield, and it is not compatible with The Arduino W5100 Ethernet Shield Library.
Please find the corresponding library from here: