Wio tracker GLNSS not working

Hi, first tell you im your follower since 2 years ago, and i`ve bought some products

(rephone an sensors).

I ordered a wio tracker (not the lte version) in order to investigate a litle and find if its situable for my projects/business. (and 2 groove accelerometer sensors)

It arrived last week and after getting familiar with the wio tracker i have been able to make work all features i need, gsm, calls, sms send and receive, sensor and detect movement, leds… but it had been imposible for me make GPS work.

I’ve tried all your examples, all your codes. but nothing happens even if i’m outside for a long time.

your “better” examples always return coordinates (0.00000,0.0000)

(i mean better because raises no AT errors) (i think that this example raises no error cause you use a function that dont wait for AT response)

finally i get down to AT commands and found that AT+QGNSSRD? command always fail. (code 7103 i dont remember, it was “the operation could not complete”)

in adittion I tried to deactivate epo by AT+QGNSSEPO=1 and also get a failure code.

I have tried the whole list of at commands, either from MC_20_AT_Command_Manual and MC_20_GLONASS_AT_COMMANDS manual of your documentation section.

My WIO TRACKER is connected thru 5V microUSB cable and a 3.7 Battery.

A sim and sd inserted (both fully functional) (i’ve tested both by arduino ide codes and by at commands)

The wio tracker board is v1.4 from 05/15/2017

IM DESPERATE. Maybe the glonass microcontroler is broken??

Any idea / suggestion?

If you need more information just ask.

Thanks in advance.

Hi there,

Thanks for following Seeed. I connected GPS antenna and plug the SIM card. I tried https://github.com/Seeed-Studio/Seeed_Wio_GPS_Board --> <LINK_TEXT text=“https://github.com/Seeed-Studio/Seeed_W … dinate.ino”>https://github.com/Seeed-Studio/Seeed_Wio_GPS_Board/blob/master/examples/MC20_GNSS/GNSS_Show_Coordinate/GNSS_Show_Coordinate.ino</LINK_TEXT>.

I got below output from serial COM. But your AT+QGNSSRD? command always fails. It seems something wrong with the board.

Would you please use the Seeed_Wio_GPS_Board library and give a try? I will update the wiki to use Seeed_Wio_GPS_Board library. Please let us know if the issue is not solved. thanks.


Power On!


+CFUN: 1







GNSS: 0.000000,0.000000


GNSS: 104.054185,30.698198


GNSS: 104.054063,30.698158


GNSS: 104.054045,30.698153


GNSS: 104.053982,30.698123


GNSS: 104.053987,30.698128


best rgds