WIO TERMINAL wont run example sketch

In Arduino IDE I uploaded a Wio Terminal Sketch 'Celluar Automata. It compiled with success, but the Wio Terminal screen showed nothing just black screen. The same thing happens each of the examples from the 320x240 folder from the Seeed Arduino LCD Repo.

The ONLY sketch that does work is the Blink sketch.

All the example Sketches from the Arduino LCD Repo DID WORK 3 days ago. I mistakenly deleted the TFT-ESPI library then the sketch would not work. I put the TFT-ESPI library sketch back in the Libraries folder and Uncommented the line in User_Setup_Select #include <User_Setups/Setup1_IlI9341.h to no avail. Am I leaving any steps out?

Please help me. I have spent the last 3 days on this.

Wio Terminal’s TFT library has some historical reasons, it can’t coexist with any other TFT library, otherwise it will report an error. Secondly, if you have ever touched the TFT library in Wio Terminal on-board, I suggest you to re-install the whole SAMD on-board file and reinstall it.

Thank you very much for the help. I will give it a try.

When say to re-install the whole SAMD onboard file…How do I do that please?

Sorry I think you mean thru TOOLS Board Mgr.

Yes, this can be done through the Development Board Manager

Hi did what you suggested but still have the same problem unfortuneately.

Can you provide a screenshot of your on-board files and a screenshot of the Arduino IDE library?

I fixed it. I removed and reinstalled the Seeed Arduino LCD library and removed the TFT-eSPI library for the libraries folder and now it works! So, relieved. I want thank you for taking the time to help me. I really do appreciate it.