WIO Terminal on Raspberry Pi 5

I am new to the WIO and could use some help.

I am trying to compile on a WIO Terminal with Arduino IDE 1.8.19, I keep getting this error.

/home/pi/.arduino15/packages/Seeeduino/tools/arm-none-eabi-gcc/7-2017q4/bin/arm-none-eabi-ar: error while loading shared libraries: libfl.so.2: cannot open shared object file: No such file or directory

Any help would be greatly appreciated, thank you!

Hi @mrpeterc ,
Could you tell me your Raspberry Pi 5 settings?

  1. cat /boot/firmware/issue.txt
  2. uname -a
  3. dpkg --print-architecture
  4. Did you install Arduino IDE Linux ARM 32bits or Linux ARM 64bits?

Thank you for your response,
Raspberry Pi reference 2023-12-05
Generated using pi-gen, GitHub - RPi-Distro/pi-gen: Tool used to create the official Raspberry Pi OS images, 02b371de1a87bbe70cfcbd498527067a7d2ee6ca, stage4

Linux Pi5S1 6.1.0-rpi8-rpi-v8 #1 SMP PREEMPT Debian 1:6.1.73-1+rpt1 (2024-01-25) aarch64 GNU/Linux

dpkg --print-architecture

I used Pi-Apps to install Arduino IDE, not sure which version it downloaded. I am using 1.8.19, if you can tell me how to find the 32 or 64 bit, I will check it and post the results.

Hi @mrpeterc ,
Thanks for message. :blush:

I was able to reproduce it on my Raspberry Pi 5.
Looks like we have to install libfl.so.2 manually.

sudo apt update
sudo apt install libfl2


Thank you! I ran the install for libfl and it worked. I have a question about the 64 bit version of Pi OS, when I try to install the SAMD boards, I get a bossac error. That is why I went to the 32 bit version. Is there a fix for the 64 bit OS? I apologize in advance if this question needs to posted elsewhere. Again my thanks for your help!

Hi @mrpeterc ,
I’m glad it’s fixed. :blush:

Could you give me some details?
(environment, error message, …)

Thank you takashi for your help!

This was a fresh install RPi5 64 Bookworm,
uname -a:
Linux pi5r64d 6.1.0-rpi7-rpi-2712 #1 SMP PREEMPT Debian 1:6.1.63-1+rpt1 (2023-11-24) aarch64 GNU/Linux

Arduino IDE 1.8.19 64 bit
Additional Boards Manger URLs:

Seeed SAMD Boards v 1.8.5

Tool bossac is not available for your operating system

Hi @mrpeterc ,

I found same issue. :pensive:

Hi Takashi,
I posted this question to the Arduino forum, I received a response that fixed the problem: Here is the post, Bossac error on arm64 for WIO terminal, SEEED SAMD Boards - Hardware - Arduino Forum

1 Like

Hi @mrpeterc ,
Thanks for information!

Workaround added to the issue.