Wio Terminal gyro demo not compiling

Has anyone managed to get the PlatformWio TerminalDemoWio Terminal Displaying Gyro working?
I’ve installed all required libraries but when I try to compile it I get an error that says min has passed too many arguments
There appears to be 3 when it says it only needs 2

Hi @drew12parker12

Can you provide a screenshot of the compile errors please, will try to recreate the situations

This is what im getting in the error mesage.
Ive installed all the libraries and can compile and run my own code, really want to see if this will work. The monitor raspberry Pi program works great, just not this

Arduino: 1.8.12 (Windows 10), Board: “Seeeduino Wio Terminal, Enabled, 120 MHz (standard), Small (-Os) (standard), 50 MHz (standard), Arduino, Off”

In file included from c:\users\drew\appdata\local\arduino15\packages\seeeduino\tools\arm-none-eabi-gcc\7-2017q4\arm-none-eabi\include\c++\7.2.1\list:60:0,

             from C:\Users\Drew\Documents\Arduino\libraries\Seeed_Arduino_Linechart-master/seeed_graphics_define.h:26,

             from C:\Users\Drew\Documents\Arduino\libraries\Seeed_Arduino_Linechart-master/seeed_graphics_base.h:2,

             from C:\Users\Drew\Documents\Arduino\libraries\Seeed_Arduino_Linechart-master/seeed_line_chart.h:2,

             from D:\Documents\Seeed Stuff\AcceleratorReadings.ino\AcceleratorReadings\AcceleratorReadings.ino:2:

c:\users\drew\appdata\local\arduino15\packages\seeeduino\tools\arm-none-eabi-gcc\7-2017q4\arm-none-eabi\include\c++\7.2.1\bits\stl_algobase.h:243:56: error: macro “min” passed 3 arguments, but takes just 2

 min(const _Tp& __a, const _Tp& __b, _Compare __comp)


exit status 1
Error compiling for board Seeeduino Wio Terminal.

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.

Hi @drew12parker12, Which demo you are trying to compile? can you share the file?


I may know the answer of this, what’s your Seeed SAMD board versions, please update to the latest 1.7.6 and try again.

I am using the AcceleratorReadings.ino example at this link https://wiki.seeedstudio.com/Wio-Terminal-Displaying-Gyro/
I have installed all the required libraries and updated the SAMD Board to the latest version 1.7.6
I have not changed any part of this project, just opened it in Arduino and tried to verify if.
Every single time it fails in the same way
I have downloaded the project a number of times with the same response

@drew12parker12 I tried to compiled and I didn’t face any issues!

Can you try un-install the board definition first then install again latest board definition, caches might be a problem!

Hi. Yes, I’ve had this before. For example:

I am unsure what it conflicts with (besides the Arduino min() function) but my solution was to create a new sketchbook location such as this:

Then I ONLY put in the WIO libraries… then there are no conflicts as you can see (though I do get warnings it does compile):

Can share your code? I’ll try to compile it!

Hi everyone.
I’ve given up on this one now!
Tried all the advice given by everyone, thank you, but none of it worked!
I eventually uninstalled my Arundio software, all libraries and packages, downloaded all the latest versions of everything, reinstalled and tried again, still the same error message!
Weirdly I get the same error on both my Win10 and Win8 machines!
I reinstalled everything on my Win10
Thanks for all your advise but it looks like I’m just not going to get this one to work
All the examples that come with the seeed Wio package seem to work ok so my Wio is okay
I will tinker with this now and again and if I manage to get it to work I’ll let you know!
I’m baffled!

I’m using the code in the link mentioned earlier. Haven’t changed it at all

Tried this but it didn’t work. Thanks for the advice

@drew12parker12 Did you tried to reinstall the board manager? , I tried to compile the code you mention and I did’t find any error!