Wio rebooting into bootloader during WiFi flash

I got my wio yesterday and have been trying to update the WiFi, I have tried 2 windows 10 pcs and 2 raspberry pi/Linux pcs but everytime I erase or flash the wio goes from the “burn fw” screen into bootloader and the process fails.
Any ideas what I might be doing wrong?

Ok, had a sleep… Tried again with flash files in a separate folder and it seems to have worked. Is that all that I was doing wrong? If so then it needs to be made clear that they have to be separated.

I followed a random guide (possibly the seeed one, I can’t remember) to update the WiFi firmware on my windows machine, making sure I put the new WiFi firmware in a separate folder

Ambd_flash_tool erase

then used the

ambd_tool flash_tool -d (name of the folder containing the WiFi firmware)

commands to erase and then flash the firmware and then used the Arduino IDE to flash the version software onto the wio, opened the serial monitor and there was the updated WiFi version numbers.

Hopefully someone else will find this information useful and manage to update the firmware.