Wio Link setup issues

I’m trying to set up my wio link, using my Nexus 6p (Android M still).

  1. when I’m already connected to a wifi, the app “unfortunately stops” when trying to connect.

  2. no matter what I try, which network or which kind of password, I always end up with “Error. Wio Link can not connect to the router. Maybe AP password is wrong or AP connect timeout Please reset Wio Link to config mode and try again.”

Those of you who managed to config them, what did you use?


I have been having the same problem, I have tried two access points and 3 different mobile phone and still no success.

Just trying to find information on how to update the board via usb, if possible. As I had a similar problem with the spark photon with the update sorted.

I presume it’s possible to connect to it’s network, then program it somehow using something else than the app. I wonder where this information is.

Just got mine on after about 30mins of fiddling with it. I had to first get it onto a Wifi network without any WPA2 (open Wifi network.) Let it connect, and verify I could connect from the app. Once done, I reset it again, then was able to add it to my normal Wifi network on WPA2 by holding down the config button and reconfiguring again.

Hi all,

The app send wifi password with udp protocol.

If very difficult to configure with app, I suggest use Wio Link Command Line Toolset. It use usb to config.


It support Mac/Linux/Windows.


Very short tutorial of how to connecting Wio Link to WiFi via Wio-Cli.


Happy hacking!

Hey Seeed there are a lot of people having the same issue on android 6 … Can we please have some clarity on either when a fix will be available or a proper work around (not CLI)!

OK so no help from Seeed on this issue. Has anyone had any joy with android 6+?
Latest app update has not fixed the problem.
It is annoying the hell out of me… Is there a workaround without going down the CLI route?

I still have a bag of wio link (10) here I haven’t set up.

Hi seeedstudio201410,

Can you tell me when "App then says it is retrieving IP from Wio”, your phone’ wifi is back connect to your AP?

By default the phone will automatically connect to the AP before Wio.

And the wio blue LED is lights on or blink?


It’s not connecting back to my normal AP, no.

The blue LED is PWMing slowly from 0 to max and back with a period of about 2s,
both before the procedure and afterwards.

“Wio can not connect to your AP.”

The Wio does not send a DHCPREQUEST on my LAN, so I don’t think it manages to connect at all.

(PS. How do I get an admin of the forum to change my username?)

Edit: This happens regardless if it’s a WPA2-private or fully open network (2.4GHz). Access point is an ASUS RT-87U. The Wio Link never turns off it’s own AP.

I had also a weird problem when first trying to configure my wio link.
Always failed nothing worked.
I then deinstalled the app, reinstalled it, made a new acount and everything like a total noob with the supplied guide and it worked perfectly.

But I use an iPad because my phone if on android 4.xx and the android app can’t be installed:(.