WIO Link not connecting to Android

Received my WIO link today, super excited, but got stuck quite early on.

Using the App V2.1.2 on Andriod V5.0.1 on a Galaxy S4.

After pressing the Config button for 4 seconds, the blue light stops flashing, pressed the ‘Got Ready’ button and the app should list the WIO to connect to. But nothing happens. Pulling up and down seems to trigger a refresh, but still nothing appears.

I can see the WIO in list of Wifi networks on the phone (if you held down the config button on the WIO). I tried connecting to the WiFi first, as well as during the time I was running the app. The phone connects, WIO gives me an IP, but then I get a ‘connect server failure’ message in the App when I press the ‘Got Ready’ button.

Rebooted the phone, ‘forgot’ the WIO network settings… Nothing seems to help, ran out of ideas to try … any suggestions?

Found the ‘Advanced user Guide’ in Github, tried the instructions under ‘Bricked WIO Link’ in case the firmware was out of date. The instructions worked, but the WIO is doing the same thing.

I was given the following to try, bit obscure, but it works!

Making sure location services is enabled for the Android application makes it connect.

(I suspect it tries to work out which server to use for the backend at this point. )

For Android 6.0 and later, must to open Location Service. Cause the new Android Permission System.

About the LED status, pls check this post:

or Here: github.com/Seeed-Studio/Wio_Lin … tatus-leds

I have an Galaxy Note 3, and had to turn location Services “Off” for it to locate and display Wio Link

Here ‘connect server failure’ message, because your WioLink need connect WioLink Server to get new WioLink Resource. But now your phone connect Wio AP which can not access network.

Can you tell me your Wio AP’s name ? The app should filter and list just the “Wio_xxx” or “WioLink_xxx”.

Is there any description of the protocol used by the apps to configure the WIO?
I’d rather have a linux script configuring them from my laptop.

(Still haven’t got the apps to work. 10 little WIO sitting in a box… Location is certainly not blocked for the app.)

The app use UDP protocol. And The Wio Command Line Toolset use serial.
The Wio CLI (github.com/Seeed-Studio/wio-cli) support Mac/Linux/Windows. You can try it.