Windows freezes when i try to access xiao

hello, I just got few xiao boards, and first i tried to upload simple sketch with arduino ide, it wasn’t working. I am getting error while uploading it:

Set binary mode
No device found on COM8
An error occurred while uploading the sketch

then i wanted to try to use circuit python. When i connect board to pc, quickly double short rst pins, i get “Arduino” window opened, but when i try to paste or drag an drop uf2 file windows freezes.

my pc is windows 10 64bit, i tried multiple usb ports

Hi Aleksandar,

Have you selected the correct COM port which relates to the Seeeduino XIAO that is connected?

In Arduino IDE, under Tools > Port

Let me know how it goes.


Hi Lakshantha, thanks for helping, but the problem was solved by restarting my PC :man_facepalming: now it works like a charm :slight_smile:

1 Like

Installed memory that is not sufficient and paired with a CPU with greater processing capacity may cause the Windows to freeze. If no malware or corrupted files are found, and resetting the computer does not resolve the problem, increasing or upgrading RAM may solve the problem.

Hope You Find This Useful,