Windows 7 won't recognize the DS203

I am following the steps in the Upgrading Firmware instructions:
Power off the device and connect it to your PC with a Mini USB cable
Boot the device into upgrade mode by holding down the play/pause button (">||") while turning on the power
the DSO Quad/dso203 will be recognized as storage device

Following these steps my Windows 7 computer gives me a “USB Device Not Recognized” message window and the unit doesn’t show up as a “storage device”. There aren’t any new drives showing up in the explorer window.

Is there a setting I am missing?

Since posting this I have found that when my DS203 is turned on normally (not in “upgrade mode”) my Windows 7 computer recognizes the unit as a drive. I copied the appropriate files to the unit (.ADR, .BIN, SYS.hex and APP.hex) while it was turned on normally. Now in “upgrade mode” it is still not recognized and says “Please copy Hex or Bin File to the DFU Virtual USB Disk”. So it seems that while I saved the files to the unit they didn’t “take”.

Any insights would be appreciated.

Here is a bit more info on my unit:
Device Firmware Upgrade V3.11C
Hardware 2.60
DS203 Mini DSO Sys Ver 1.51
DS203 Mini DSO APP (Plus A1) Ver 1.00

I don’t know the answer to your problem, but here is some info:

  1. The files have to be copied when the device is in the bootloader mode.

  2. My Windows 7 seems to recognize the device just fine, both in bootloader and in normal mode.

Maybe try another computer?

Thanks! I got it to work by switching to a different port on the same computer. I guess not all USB ports are created equal.

I have the same problem. Unknown device when in bootloader. But, i have had problems with flash drives over 4 gigs on this computer. I guess it doesn’t matter how much memory, storage, or whatever i stuff into this thing, its still just a netbook.

Nope. Tried on different computer. Same thing. Unrecognized device when in firmware mode. Any thoughts?

Edit: A suggestion was to try new cable. Sure enough, cable that came with unit wouldn’t upgrade firmware. Different cable did just fine. Hope this helps someone else.

Windows 7 32 bit will work 64 bit not recognize in my case stick with the one work, if you moved to other PC not work then come back with the one even work before , still can not read the files in the drive then you have to re format the drive again , I has try a couple times like that . Hope it help. Also you USB cable are different too try to swap around see with one work and keep used that for next time .