WIN8.1 and Quad V2.81 USB Interface

Has anyone come up with a solution to interface Win8.1 with the Quad?

I cannot get mine to work and finally corrupted my quad. Can’t load anything to the DFU.

Do I need to go back to an XP system?

Very frustrating.


Win 8.1 works with my hw v2.70 DSO.

I think I remember initially having trouble finding a USB port (3.0/2.0) on my Win8.1 laptop that allowed the DFU device driver to install.

Shouldn’t need a driver for a normal Windows USB external drive, but DSO should be formatted by Windows to FAT32.

For DFU use, you may need to try different USB ports and reboot the computer a few times. Check the Device Manager to see that the DFU device driver has been installed from the connected device. Should show, with some delay, in Device Manager (Windows 7 or 8.1) under “Disk drives”, as “Vertual DFU Disk USB Device” (I think they meant “Virtual”).

Also try different USB cable. Some sellers ship bad USB cables, quite many have had trouble upgrading firmware and solved it by switching the cable.

No good luck, only bad. New cable with same results. Tried 3 different PCs with same results. Occasionally it will come up as DFU disk drive (button 1 pressed) but I cannot transfer any files.

Just turning on it comes up with screen that states FPGA config OK and hangs.

Maybe it is time to reload DFU code or whatever…


As of this morning I managed to get my Quad running again.

  1. Had to use a Win 7 machine, would not work with Win 8.1

  2. Reloaded all files and here comes the interesting part…
    After powering up Quad with 1st button pushed, the USB (DFU) drive appeared and I loaded each file. The unit never reset or changed the file extension. I powered off after loading each file and repeated the process for each file by powering off and then back on. After I did this for each file the unit came back to life.

  3. I loaded Wildcat 4.0, 4 slot version. It came up fine although on power up it states it could not find the paramter file and then proceeds to load.

It would seem that the bootloader still has an issue somewhere but at least with this work-around the unit is back to being functional.

Wildcat 4.1 is the latest version (look for the download link on page 35). After backing up your DSO WPT and any other files, use the Windows File Manager to re-format the DSO flash drive. Then copy your files back to the DSO; your WPT parameter file should then load properly.

The problem with Using Windows 8.1 initially, is not being patient enough to allow time for the DSO drivers to load. It may take several minutes or longer to load the drivers and may require a few Windows reboots.

I loaded 4.0 as it is faster from what I read (my memory isn’t so strong). Also the files created when I got everyone loaded and running (original files) I had a .BAK and .PAR file. So I am assuming the parameter file is the .PAR. I saved the files, reformatted, reloaded original files, created the 9 config files from the .PAR file and 4.0 seems to work just fine. The only problem I have now is learning how the buttons work. It is a tedious process (for me).

Trust me, I have been very patient with Win 8.1, The only driver it will recognize with the DFU is the Microsoft driver version: 6.3.9600.16384. This is the generic driver as I understand it.

I am not sure what other driver I can use. Have not done any extensive research into other drivers. Win 7 uses a Microsoft driver as well, version 6.1.7600.16385. That works!!


The DFU driver resides on the DSO. It only loads from the DSO when you power up the DSO in DFU firmware upgrade mode and connect to the PC via USB cable. The DFU driver is very slow to load from Win8.1. You also may try another USB slot on the PC.

The driver loads OK (I am assuming) and it does take a bit to load on 8.1. I can see the drive and can load a hex file but it never does anything with it. I took the unit to a win 7 PC and did the same thing. It upgraded to 4.1 without issue.

Again, with my unit I get no indication of the upgrade, I have to power down the Quad and on power up it tells me what version loaded. The unit is working just not like the manual states.

By the way Borland, thanks very much for the info on the driver methodology. Guess I have to start learning how to program this beast. Is it possible to use the ATMEL Studio IDE for compiling and loading to the processor? I have that loaded but never tried interfacing to the Quad.


It takes a while to read up on this device. I bought a broken one, so I had time to learn quite a bit while waiting for repair parts. Have it fully functional now, but I still have lots to learn.

You can see the Windows driver loaded from the Control Panel’s Device Manager. The DFU driver will only show up when the DSO is USB connected and in DFU mode.

Haven’t looked into the open source firmware. I bought the DSO to use just as a diagnostic tool and don’t really have much time for that. There’s a wiki about application development, here…

For anyone else that ends up with the same problem, you need to flash DFU v3.45C for proper Windows 8 / 8.1 / 10 support.
Here is a tutorial: viewtopic.php?f=26&t=6186