WiFi shield - dirty chars


I’m using a WiFi shield with Arduino Uno (but I also tested it with a Olimexino board).
I’m using the default TCP sketch.
If I check the communication with the WiFly module I can see a lot of dirty characters.
At the end of the init procedure a TCP channel is opened and it works, but I’d like to understand why I have all this trash in the communication.

Here an example of what I obtain:

$$$CMDset w join 0
)Ñÿ›ÿ joiƒþ
AOKset comm remote 0
<2.2ùlûeþ½ÿµÿ ÿmote 
AOKset w linkmon 5
<2.23> •ÿtÝÿ ¥ÿnµÿoþ5
AOKset wlan auth 4
<2.23> •ÿtÝÿl¹ÿ Õÿtþ4
AOKset comm idle 0
<2.23> •ÿtÿoµÿ ‘ÿlþ0
AOKset w ssid MyWiFi
<2.23> •ÿtÝÿ Íÿiþ¥ÿFÿ
AOKset w phrase 1234567890
)Æ&™³Ÿ +£Ù÷ÁÿÉÿ›ÿe Ñþ1áþÅþ£þ
AOKset ip dhcp 1
)Æ&™³Ÿ +£Yôþdhcp 
<2.23> …ÿv5ÖLØ5Ý·ring in config
<2.23> exit

I tried to use different RX/TX pins but the result still the same
What could be the reason?


You can ignore it , the main point you need to care is connection without errors
And we will fine down our product . :sunglasses:

Same problem for me (working with Arduino Uno, too)… but I can’t connect to the “virtual remote server” :neutral_face:


It’s very strange but I’m connected to my local network as you can see


I’m using WiFly Ver 2.23 … and also made another trial opening my wireless network but it doesn’t work neither :cry:

Thank you for your help :wink:

Something you should to know about. :mrgreen:
Everyone has their own IP address,so you need compile it like this" while(!Wifly.connect(“your own IP address”,“90”))" :wink:
Hope they might be helpful to you. :slight_smile:

Best Regards

Thank you… but it wasn’t not explanied very well in wiki of your product :frowning:

What’s my OWN IP ADDRESS? Anyone in my domain? Router one? PC that I’m using? :confused:

I tried with my PC one… with my router one… and with my Arduino one too ( … but always with the same error :frowning:

The IP thing… EACH device in the network must have a unique IP. So the router (also called the gateway), your computer, your phone etc… ALL get a unique IP address inside your network… so for your programing, just choose one that is not used by other network devices.

Thank you for the info… that I known it :wink:

Have you read my previous email? :open_mouth:

I’m using DHCP … and the Arduino IP is created by my router… in this case, I previously explained, it’s

The problem is there is not CONNECTION to port 90 of this IP :smiling_imp:


The remote server IP … it’s my PC IP :astonished:

Thank you for nothing :imp:

The problem seems not very hard, isn’t it :stuck_out_tongue:
But i’m sorry for saying undetailed… :frowning:
The problem have been solved, so,enjoy it . Have a nice day :slight_smile:

Best Regards