Wifi and bluetooth problem

Today I have a problem about the WIO Terminal bought the last month.
As requested by the website SEEED, I updated the Realtek RTL8720’s software. Everything was working well. So, I tested the following example : “Server connect to Client of Smartphone”. Since, I was able to develop many graphic applications.

Yesterday, I tried to develop a bluetooth application but, the WIO Terminal was no longer responding. I saw an new version of the Realtek RTL8720 ( https://github.com/Seeed-Studio/seeed-ambd-firmware/releases/download/v2.1.2/20210317-seeed-ambd-firmware-rpc-v2.1.2.zip ) and I did it.

After installing the above firmware, The process was installed correctly, I tried to read the version with “the Check RTL8720 Firmware Version from Arduino IDE” , but, I had the same issue, the Terminal is still no longer responding. The others terminal fonctions still working. I think so, it the problem is linked to the radio module.
What do you think about it ? Do you have some advices ? Do you know if someone has the same problem?
Thanks for your support !

Hi @fab95000,
no, I didn’t have such a problem. I would try to repeat the RTL8720 firmware update.
Did the ‘rpc_system_version()’ command ever work for you with firmware v2.1.1?
Best regards

Hi RoSchmi,
As requested, I tried to repeat the RTL8720 firmware update with the v2.1.2 version,
but the RTL8720 still doesn’t respond.
Yes , the ‘rpc_system_version()’ command worked after the first update with the v2.1.1 version.
How can I send you, my log of programmation and my log of IDE compilation ?
Thanks so much for your support !
Best regards

Do you mean that it was not possible to update the RTL8720 firmware?
I’d suggest that you decribe exactly and verbosely the steps you made to update the firmware. Perhaps someone can find out that you did something wrong inadvertently.