Wi-Fi Shield connects to router, but software fails


I’m having some problems with my wifi shield. I am able to compile and run the examples from the github page, the shield flashes green and red lights until it eventually connects to my router ( green light turns off, red still flashing ) it will sit idle for a decent amount of time while I can ping the ip address of the shield and everything seems to be fine, then the connection will timeout im assuming and wifly.join will return 0 and fail. I’ve tried a few different libraries and they all kind of do the same thing- wondering if it could be a defective unit or im just doing something wrong? I have a 9v dc power supply plugged into a funduino mega 2560 board as well ive tried connecting to my apple router and iphone as a personal hotspot, the same thing happens… Its so close because it gets a valid ip and im able to ping it, but the handshake never seems to complete and im not able to send / receive any data.

Any help would be greatly appreciated!!


a little update, I was able to telnet into the shield from my computer once it obtains an ip address, I am able to run $$$ and get into command mode and run whatever I need.

Unfortunately after a bit of further investigation, the sketches I have been using ( the examples from github ) are failing when trying to enter command mode.

I’m wondering if I possibly have the incorrect pins set? I’m using the tx / rx pins at 2,3 is this correct? Is there any reference online as to what the different pin configurations are for?

when I try and run wifly.available() its always coming back as 0, is there any kind of test I can run on the serial connection to see if the board is seeing the shield? I’ve verified that the SD card is working as intended and I can telnet to the board, just cant seem to get the arduino to speak to the wifly library correctly…

Any help would be much appreciated!! I’m a total noob with some C experience and its my first project.


It seems that you used Mega2560 with wifi shield, right? If so, please pay attention to the SerialSoftware library, not all digit pins can used as serialsoftware pins. See this FAQ of wifi shield, maybe you can get a solution about your problem.