Why my wiolink can't connect to the router?

I am not able to connect to my WIO. After sending the wifi password to the wio link, an error message appears telling me that Wio Link can not connect to the router.
The password is correct, though. Tried it a couple of times. Any ideas?Thx


I am having the same problem, I have tried 2 routers and 3 mobiles and still have not got the thing to connect.

There must of several people with the same problem.

Also I can not see anywhere I can post a support question :frowning:

Does your access point have WPA2 enabled? I had to first connect to one that was unsecured but had Internet connectivity, let it connect with the app and run for a couple mins. I was then able to reconfigure it to point to me normal secured network.

All my routers have WPA2 enabled. I might try to set up a dummy network without one if you say it helps.
This should probably be in the FAQ…

@seeedstudio201410 Mine all do as well. I ended up using a 2nd phone set up as a hotspot, and configured the Wio Link from a 2nd phone.

same for me. send the password and it waits then comes back with no connection. wifi router uses “wpa personal” security/password.

I am having the same problems and the getting started instructions are great if you have been working with the device for months or more, but just getting started the cute little video is no help and is confusing. What is “-4s” supposed to represent - a delay of 4 seconds or holding down the button for 4 seconds or is it just a typo???

What is the theory of operation of the device.?

What should the USB cable connect to - any USB port for power or is there some hidden stuff?

I can see the device on my Samsung phone, but it says that it is not in range when it is sitting right next to the phone.

I can not see the device from my WiFi router?

Hi, I had same problem,but I settled it.Please make sure that you choose correct server ,China mainland select China server,others select International server. :slight_smile:

Hi,I’m Neville Kong,the community operator of Seeed Studio.You should power it on using USB port , click the ‘‘GOT READY’’ , then hold down the button for a few seconds.I’m sorry for the confusion,we are improving that little video.

Same issues here.

I connect my ipad to my wioLink. After this, I tried to connect the wiolink to the WiFi router using the wiolink ipad app but I only ended up getting a time out error.

After reading an earlier post, I tried to use internet sharing on my phone(instead of using the router) and connect the wioLink to internet but I still end up getting time out errors.

Any pointers to get around this problem is appreciated?

update on the wiolink connection issue.

I changed from ipad to an android phone for connection. I was able to successfully connect wiolink with the android phone- oneplus x. (not sure what was the problem with ipad)

Neville, this doesn’t help for me at all. I can connect the app to the AP that the wio sets up, but after telling it about my wlan it doesn’t connect and I have to restart. Also see this thread


same here: cant connect with iphone 6s :frowning:

Maybe we need to fix a lot of bug in App :frowning:

Can you guys try the wio-cli tool first? It would be more hard core than App :slight_smile:

Reference: github.com/Seeed-Studio/Wio_Link/issues/8

  1. Install the driver for USB to Serial, download address silabs.com/products/mcu/Pag … ivers.aspx
  2. Open a terminal
  3. Install the cli tool as follows: sudo pip install wio-cli (Windows and Linux have to install python first)
  4. Type wio login and follow the instructions.
  5. Run wio setup
  6. Perform the following conversation:
> Setup is easy! Let's get started...

! PROTIP: Hold the Configure button ~4s into Configure Mode!
! PROTIP: Please make sure you are connected to the main server

? Would you like continue? [Y/n]: y
> I have detected a Wiolink connected via USB.
> No nearby Wiolink detected.
? Would you like to wait and monitor for Wiolink entering configure mode [Y/n]: n
Quit wio setup!
? Would you like to manually enter your Wi-Fi network configuration? [y/N]: y
> Please enter the SSID of your Wi-Fi network: DeBruijnFritzBox
> Please enter your Wi-Fi network password (leave blank for none): bdboksdoorn30
> Please enter the name of a device will be created: WIO_01
> Here's what we're going to send to the Wiolink:

> Wi-Fi network: [ssid here]
> Password: [your pass here]
> Device name: [whatever you like to call it]

? Would you like to continue with the information shown above? [Y/n]: y

> Send Wi-Fi information to device success.
> The Wiolink connect to main server success.
> Set Wiolink name success.

> Configuration complete!

I can’t connect at all after following the instructions - no device found.

jakwi-macbookair:~ jakwi$ wio setup

Setup is easy! Let’s get started…

! PROTIP: Hold the Configure button ~4s into Configure Mode!
! PROTIP: Please make sure you are connected to the main server

? Would you like continue? [Y/n]: Y

No found device! Plese connect your Wiolink with USB.

Er… It’s my wrong. We need to install USB serial driver first in last post.

Here is the driver download address: silabs.com/products/mcu/Pag … ivers.aspx

I had same problems with both my WIO Links
I could not set up the WIFI connection with my nexus 6 (android 6.0.1) and not with samsung but it worked with a caterpillar.
Somehow WIO is very picky. Maybe it only works with older android versions (location service was switched on).

I hope this bug get’s fixed. Took me quite some time to figure out this work around.
Good luck

It seems to be an Android 6 issue? If you connect to the network manually you get further.

Hi friends,

I make a test Wio app. Set timeout to 60s.
dropbox.com/s/511wep5c2pfdf … g.apk?dl=0

Please install it and feedback.


I’m havin the same issue. Neither the iOS app nor the CLI client on macOS is able to transfer the WiFi settings so that my Wio Link would connect.

Is it possible that the Wio Link has problems with WPA2 passwords that have spaces in them?