Why are there no install instuctions for ODAS and the Respeaker Mic Array V2?

All of the install instructions on the github and wiki dont work. And the firmware install instructions do not work either.

Is there a blog out there that has step-by-step instructions that actually work that you could link me to please?

Thank you!

1 Like

Hi @Johnkubik
The wiki has detailed steps to install the firmware and set up ODAS.
What’s the wrong information that you got when you fail to do it?

@jiachenglu

The install instructions do not work and are not clear.

And I am asking about how to get the ODAS studio working with ODAS core.

The firmware instructions do not work when tried on ubuntu or rasperberrypi python2 or 3.

The instruction you are talking about on the wiki are extremely vague:

  • Step 2. Get ODAS Studio and open it.
  • Step 3. The odascore will be at odas/bin/odaslive, the config file is odas.cfg.

Step 2 does not talk about how to install the software! It is very difficult to install ODAS Studio.

Step 3 does not talk about which config to update. Do I update the config file on the remote system, or the local system… and also odas/bin/odaslive does not exist anywhere on my system after trying to install ODAS Core or ODAS Studio.

it isnt in ~/odas/… or anywhere else.

Do you happen to know how to configure the ODAS Core to work with ODAS Studio?

Hey, i am having the same problem there is nothing on odas studio i am using respeaker version2.0 i can see no sources in the odas studio everything looks fine but its not working.

I have exactly the same problem. Did you guys solved this problem and find better tutorial

Hi,

I installed odas_ros to my robot which already has respeaker array. When I roslaunch odas_ros odas.launch it runs fine but it tpics don’t publish any source.

I don’t even know if its connected to respeaker or not.