White screen - Please bring me up to speed - info included

I have a firmware problem (at least) with a “white screen” Nano that I just bought. Either I am not loading the correct firmware or there is some sort of hardware issue, as well. Here is what I can tell you. It will seem as if I am writing a novel, but I might as well give you all of the information I have up front.

Identification: This is what I would think is a DS201 V1. It has the black case with the white 4-way rocker button that that looks like an MP3 player. The printed manual is titled “DS201 User’s Manual” and describes the later firmware update procedure where hex files are simply copied to the device and then acted on by the device. When attached to my computer, the firmware storage area is identified as a removeable disk labeled DFU V_329_D. That’s as much as I can tell you about the firmware or hardware numbers because they are not displayed during normal boot up or when booting while holding the “-” key depressed.

This device seems to be genuine and not a countefeit since it is very well constructed and has the printing on the back of the case. The box is marked “SainSmart Pocket-Sized…cope ARM DSO Nano DSO201” then " New 20-010-200 13.12.03". There is a bar code with the number X00091X0NZ under it. Finally, there is a sticker that is marked “MR90 CX78” for whatever that’s worth.On the end of the box is a label identifying the LI battery as a PL383840. Came complete with probe, USB cable, vinyl pouch, cloth bag. (By the way, I’ve also tried a different USB cable.)

It did not have an SD card installed. I have installed an inexpensive MicroCenter 2 gb car formatted as FAT16. I have no other info on the SD card specs other than that it is about three years old and inexpensive (and probably not super-high speed).

Using both Linux and Win7, I have been able to load numerous versions of hex files and see them change to the RDY file extension. I have seen no color in the display, just shades of grayscale. Sometimes, I get just a white screen. Frequently, I get a bunch of thin vertical lines with some flashing on the left. The versions I would think should work display a simple logo that appears to be upside down and reversed. There is one firmware that actually shows a low resolution and somewhat messed up grayscale oscilloscope, and I can see the time scale and other values changing as I push buttons.


  1. Has someone messed up the basic burned-in bootup subroutine thereby bricking this thing? I am disturbed that I cannot get any kind of menu when I boot with the “-” key held down, though it does go into the proper mode.
  2. Does it seem as if I just need to track down the correct firmware? Seems as if I should have hit one that works by now.
  3. Can someone identify what should be a “failsafe” firmware based on what info I have posted and also supply the hex file(s)?
  4. Does anything need to be pre-loaded onto the SD card?

Any advice will be greatly appreciated.


Yeah, I have one of the, I ASSUME, newer runs of the DSO201 with the black case white buttons. Had the same exact issue happen to me as well.

Turned out to be that the BenF Ver. 3.64 I was trying to install wasn’t compatible and I had to track down the patched version for our “newer” models.

Site won’t let me post a URL as a new user, so I can’t link you to the patched version, but Google “BenF_3.64APP_3.53LIB_patched_v2.zip” and you should find it. It should be the first result and take you to the seeedstudio forum attachment page 6, in which the is a patched version at the top and then the 4th and 5th down. I used the 4th and it work for mine.

Best of luck!

Thanks for the response. I can tell you that the PATCHED BenF you mentioned works with the new ones Amazon is currently selling while the updated firmware files Amazon provide a link to absolutely do not and yield a white screen even when properly installed. I have never run across a product if this type that had ZERO useful manufacturer support. The BenF software is excellent, and he and others who have worked on this project deserve our thanks and respect. However, there is so much junk scattered around the web about the Nano DSO that it is very difficult to glean any useful information. Part of the problem is that much of the information is old and refers to old versions of both hardware and software and acts as if there are no variations - which was TRUE when they wrote it but now just confuses many issues.