Warning: platform.txt from core 'MediaTek ARM7 EJ-S (32-bits) Boards' contains deprecated recipe.ar.pattern

It worries me that Link It One is shown as “End of Life” in these forums, since I only bought my board new in March and it is still being sold on Seeed Bazaar.
But anyway, I finally got around to using it. I need the Bluetooth, SD Card and GPS functionality.
I have Arduino CC version 1.8.9 I am using this older version due to compatibility issues with one of my sensors.
I am using it with Windows 10.

I followed all of the instructions to patch Arduino to recognize the board and to install a driver for Windows. I also updated the firmware of the Board as instructed.
When I plug the board into the PC, additional 2 USB ports are added, COM7 (Debug) and COM 8 (modem).

I try out a random sketch to confirm its working, and find out it is not.

  1. Standard Arduino Blink Sketch not working because LED_BUILTIN is not defined.
  2. Linkit One “battery” sketch does not work either, and it gives up the warning message:
    Warning: platform.txt from core 'MediaTek ARM7 EJ-S (32-bits) Boards' contains deprecated recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} "{build.path}/{archive_file}" "{object_file}", automatically converted to recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} "{archive_file_path}" "{object_file}". Consider upgrading this core.
  3. At the end of compilation, it says “Uploading using selected port: COM7” but I note that the Tx/Rx LEDs do not flash. Does that mean the code is not actually being loaded onto the board ? Why not ?
  4. There is Red Text at the bottom of the compilation/Linkage script::
    "C:\Program Files (x86)\Arduino_1.8.9>"C:\Users\Bryn\AppData\Local\Arduino15\packages\LinkIt\tools\linkit_tools\1.1.23\PushTool.exe" -d arduino -c -p "C:\Users\Bryn\AppData\Local\Temp\arduino_build_632412/Battery.ino.vxp" "
    Notice that there is no actual indication of the error, but maybe this is because of the earlier error.

OK, Editing this post after trying a few more things:
I retried the “Blick” sketch again, this time defined LED_BUILTIN as the value 13.
And then found that the sketch actually worked despite the above errors.
I also tried the “Battery” sketch and found that it too is working.

However I do think that the above 4 points remain valid as issues that ought to be fixed. I get that the product is end of life, but I think that since these boards are still being sold new, you ought to continue support for a while.

Thanks and Cheers.

I have done some further work on this. It is possible to edit the relevant platform.txt for the link it one extension and this eliminates the first warning.
However when I try to compile a more demanding sketch using several grove sensors such as HM3301 Dust sensor and BME680 sensor (using Bosch BSEC library) I run into further problems. It seems clear that the Arm compiler/linker supplied for the Link it One “needs some work”. I am very surprised it is such poor quality given this board has been out since August 2014. I think there has been plenty of time to get it right dont you agree.?