W5200 Ethernet Shield BUG?

Update 02-01-2014:
I was a bit to fast with my previous reaction, it is now sometimes working, and sometimes not. Sometimes it has the correct IP, and sometimes it I get the IP of
Is this due to the hardware bug? I’m not really happy to start breaking the connection before I have the acknowledgement, but I cannot find anything else on the internet about this hardware bug, accept on the wiki site of Seeedstudio.
Is there some one with the experience of using this shield with or within breaking the connection mentioned on the wiki site?

Update 29-12-2013:
I just found out that the ports on my modem are not working right, after replacing the modem it all works fine!
I’m still wondering if any one knows more about the BUG mentioned on the wiki site. If any one has some input about this, please let me know.

Dear all,

I have bought the W5200 Ethernet Shield on 11/11/2013. I’m trying to connect the shield via LAN. I have inserted a Mirco SD card of 2 GB, connect the lan via my router. and loaded the example from the library (Ethernet V2_0) “Web server with SD”. I’m able to read the output via serial-monitor, and I get the following output via serial:

Initializing SD card...initialization done. Writing to test.txt...done. test.txt: testing 1, 2, 3. testing 1, 2, 3. testing 1, 2, 3. server is at

Whatever I try I keep getting the IP adres Even though in the program it is stated: IPAddress ip(192,168,1,100);

Can any one help me, is this due to the bug mentioned in the wiki site? http://www.seeedstudio.com/wiki/Ethernet_Shield_V2.0

I did not break the connection on my board, at this moment.

Any help is welcome!

I’m sorry for that inconveniences, it is not the bug of the w5200 chip but the mistake of our designer. Please refer to the Bug Tracker on the wiki, and then w5200 ethernet shield would work well.

Thanks for your comprehension.
Best Regards

Thank you for your reply!

I think it should have been correct if it was stated on the webshop of seeed that modification are necassary on the board. Because now is seeed selling something that is not working correctly.

I will perform the modification and report back when I have tested it.

I still have trouble getting the shield to work. When I use the examples of the library the Webserver example works, but the webserver with SD card is not working, Via serial i see it is able to read and write from the SD card, but the IP adress is not correct, it becomes Any one has the same problem with the example?

The problem is R3 is not to ground connected and the logic state of the pin 45 is casual is not low or high.
From the W5200 datasheet:

In the eagle files if you drag R3 and move it you can see is connected only to the site of pin 45 and not in the other site to ground.
Maybe if you connect the r3 to ground and reconnect the cutting connection work good.

OK Seeedstudio do the right thing. You cannot expect your customers to troubleshoot your products and make delicate changes to the 5200 shield hoping that that may fix a non functioning shield.

I bought two boards which are useless. How about re-engineering the board layout, test it and send replacement boards to all of your customers that purchased the defective 5200 shield.


Does anyone have any more information on the possible issues with the Ethernet 2.0 shield? I purchased one yesterday and could not even get link on it to my Ethernet switch. I figured it was just a defective module so I exchanged it. So it turns out it was bad as the replacement shield works, sort of… The new one I got gets link, will run the webserver examples, but will randomly just stop responding. A push of the reset button usually takes care of it, but I find a shield that I have to keep pushing the reset button on not that useful. Did I get another bad module? I’m willing to exchange it once more before I just get a refund and go with another product. I see the info above about R3 not being connected to ground, etc… The shields I purchased both say v2.2 and appear to have been mfg. in February of 2014 according to the printing on the back of the shield. Would a shield of that version and mfg. date still suffer from that bug? If so is the random ‘going offline’ of the shield the behaviour the bug produces? Lastly if this is the bug causing my shield to randomly stop responding to network requests can someone give a little more detail or a pic of which side of R3 should be connected to ground and the best way to make that happen?

Thank you for your help.

Can somebody please clarify this? I purchased one of these today and have been using it for about six hours with no issues. I have the following questions;

  1. Is it possible I have an older version / newer version? How do I know if my hardware is affected by this bug?
  2. How will the bug manifest itself?
  3. The “bug fix” on the Wiki is not clear. Perhaps there is a language barrier, but somebody needs to PLEASE clarify the bug and the fix.
  4. Are you seriously expecting people to make a hardware change to this board? If it doesn’t work, do I get my $20 back?

Thanks for any feedback.

Hopefully someone from Seeed will let us know what to look for regarding the bug and the various ‘v2.0’ versions of this board. I’ve been testing the V2.2 Ethernet shield that I got to replace the one I bought that was defective out of the box. At first it would work when connected via USB only using the WebServerWithSD sketch. I took it to work to test it overnight and now it will not function at all unless my Arduino Uno (R3) is powered by an external power source (I’m using a 9V regulated supply). If I try to use it with USB power only it will not work now.

Out of sheer curiosity I purchased another one to compare against. So far… it works flawlessly off of USB power only. So that makes three of the V2.2 (all mfg. date Feb. 2014) that I have had. One DOA, one a little flaky, but will work if powered via other than USB and one that is, so far, seemingly OK. The two working ones I have both require, more often than not, that I press the reset button on them after connecting USB or external power before they will initialize and obtain a network link (red LED on the board usually doesn’t come on when applying power without also pressing the reset button). Not sure what to say. Is it a QA issue, or that ‘bug’ having different effects on two of them? I’ll keep testing with the one that seems to be OK and see if it later starts failing. I also picked-up a V1.1 Seeed Ethernet shield at the same time (got it for $10) to go with my Arduino R2 and so far it seems to be just fine.

I’d like to hear a proper explanation of the bug and what versions of the ‘2.0’ Ethernet shield it affects and maybe a close-up photo of a ‘fixed’ one.

In researching this issue I have noticed that various Ethernet shields (not just from Seeed) seem to suffer from power issues and certain ones seem to be more sensitive to power. I guess the tolerances used in manufacturing these vary quite a bit…

In case you haven’t figured it out, you need to take the zip file with all the code and add it to the library before it will work. In the code, it says

#include <SD.h>
#include <SPI.h>
#include <EthernetV2_0.h>

#define W5200_CS 10
#define SDCARD_CS 4
// Enter a MAC address and IP address for your controller below.
// The IP address will be dependent on your local network:
byte mac[] = { 0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED };
IPAddress ip(192,168,1,177);

Every time I tried to compile, I got an error. I would have to take the v2.0h out before the code would compile, but then I would get a bad address on serial check. As soon as I added the library containing the proper EthernetV2_0.h script. Now it works, no problem. Try this before you start trouble shooting to board.

Thanks for posting! I’m not sure how this relates to my issue, but maybe it will help others. Mine was definitely a hardware issue as evidenced by me testing several boards using the same code (never got any errors compiling as I was using the proper libraries from the start) and some working, some not working at all, and others ‘kind of’ working (constantly becoming non-responsive and requiring a reset). I finally wound-up with two functioning shields after a going through a few of them via exchanges at the local store I purchased them from.

Has anyone come up with an acceptable solution to these issues? I am on my second ethernet shield and both have the same issues. I am using it with mega 2650. I have modified the appropriate files and managed to get all of the ethernet and ethernetV2 examples to compile, verify and upload, but I STILL cannot get the ethernet shield to accept any ip address. I’ve tried hard coding and DHCP…nada!

Is there anyone out there that can help us?

Let’s put it this way. It costs over $30 in a store (RadioCrack)
Save yourself some money and go somewhere else. I bought this piece of junk and thought it was me that was the problem. Man, I have tried adjusting CPP and h files. Tried several different sketches.
I connected only 3 times at over 100 attempts.
I direct connected to my modem, I even sent a tracert and ping to it and it is defiantly connected, just doesn’t show up in the serial monitor or process code like it should.
Always stuck at places like …Connecting
Actually, I was trying to use the Plotly sketch after modding it. Got to the point of attempting to connect to the REST server. Never moved past that. This only worked twice.

Taking mine back and getting older technology that works!!!