V328: "USB device not recognised", yet µC works

Hi all.
Seems like I’m in trouble:

Today I received my assembled V328 and hooked it up right away… :smiley:
I already had a slight feeling that the mini-USB connector was a bit on the loose side
(well, comparing it to my PSP, digital camera and a usb hub…)
and WinXP wouldn’t recognise it as a new device…

Then, somehow, the hardware wizard showed up and I could install all the needed drivers
and played a little with the blinking LED (onboard) examples of Arduino0017 software;
everything was fine till then…

Couple of hours later, after reattaching the USB cable, the ‘best’ thing that happened was
a USB symbol in the right bottom corner of the screen showing up and disappearing
again every couple of seconds. After doubleclicking on it I get a window saying
“USB device not recognised” :confused:
Upon opening the device manager (which then keeps automatically updating every ~3-4 seconds),
the only thing I can see is an “Unknown Device” among other usb devices,
which I am unable to (manually or automatically) install any of the ftdi drivers for.

The device manager now neither shows the previously installed COM-Port,
nor the ‘USB serial converter’ (well it does, if I set it to show hidden devices… )

I tried ‘wiggling’ the usb connector, thinking it could be the reason, but
then windows wouldn’t even show me that unknown device - as if
nothing was connected at all, so wiggling doesn’t help either…

I must say, the µC seems to be working fine, since the previously programmed
LED blinking loop works just fine.
The TX and RX LEDs blink twice, then remain off for ~2 seconds and then repeat it again.

I’ve tried using different USB ports, cables, another PC(notebook), external 9V battery,
but nothing seems to help :angry:

So, in short, it did work (fem usb plug seemed loose) and then it stopped, all other
parameters being same.

Any ideas what it can be?
Could the FTDI chip be fried? (but then again - how?)
thx in advance.

I’ve tried using FTDI’s program USB View and here’s what it says:

Device Descriptor:
bcdUSB: 0x0000
bDeviceClass: 0x00
bDeviceSubClass: 0x00
bDeviceProtocol: 0x00
bMaxPacketSize0: 0x00 (0)
idVendor: 0x0000
idProduct: 0x0000
bcdDevice: 0x0000
iManufacturer: 0x00
iProduct: 0x00
iSerialNumber: 0x00
bNumConfigurations: 0x00

ConnectionStatus: DeviceFailedEnumeration
Current Config Value: 0x00
Device Bus Speed: Low
Device Address: 0x00
Open Pipes: 0

(I guess it’s the reason it doesn’t want to install any drivers)

Try your board on other PC first. If it don’t work anymore:

If your Atmega is broken, you will see some kind of upload error in the Arduino IDE and maybe the chip itself could overheat while connected. (Just buy another from depot and replace it)

If your FTDI is broken, Windows will detect the board as Unknown device. (Just buy another from depot and replace it)

To remove and replace your FTDI,

  1. Put solder “blobs” over both sides of the ftdi chip.
  2. Heat solder and carefully lift the chip, then clean the pcb pads.
  3. Align a new ftdi chip on the same position and touch quickly each pin to solder it.
  4. Ready.

Maybe seeedstudio can release a new seeeduino with a easy replaceable ftdi (like the Atmega) :laughing: because the ftdi itself is very weak

Here’s the weird thing:
I did a little ‘homework’ and found out that many people, who had that kinda problem,
->dev. id & vendor id =0x00…<-
had a bad connection on at least one pin on the ftdi chip…
(Like the ‘TEST’ and ‘AGND’ pin not grounded or a bad connection of any of the 0,1 µF capacitors…)

Here’s a even weirder thing:

just a couple of minutes ago, I applied a moderate pressure on the 2 ‘big’ capacitors with my thumb
et voilà:

Dev manager showed both the ‘COM port’ and the ‘USB serial converter’;
the com port even showed up in the arduino software, meaning I could actually
use it for upload to the board and guess what - I did! 2 times!
Every time I had a successfull upload along with an obvious result (blinking LED);
I’ve chosen different delay times for each upload to see the difference.
Once I took off my thumb from the caps., old story again ‘Unknown device’, etc…

So I guess I can conclude from it that neither the ftdi chip nor the µC are ‘really’ broken,
it’s just something else that seems to make them work improperly :angry:

[Damn, I just got the board an already spent a day troubleshooting instead of working with it :imp: ]

-in what way?


Mine where broken, not just loosen caps.

Good news to get your arduino working!

:astonished: :open_mouth:

And that with an new board?! :confused:

Right now I’m not that sure about the caps themselves;
I figured out, it’s more like ‘which way I try to bend the board’:
if bent slightly ‘inwards’, I get a working board (well, at least until I have to connect sth…),
if done the other way around, unknown device once again…

It’s ironic really, I’ve bought the board, because I didn’t wanna mess with ext. power supplies,
LPT/COM ports, etc. anymore
(not to mention that my new PC doesn’t have any of them) and here’s what I get… :laughing: :unamused:

so since it works when you press down on the ftdi chip, did you try to reflow the solder on the legs of the chip? just heat them all up one at a time and let the solder flow, maybe even add a small amount if it doesnt look like theres enough there. It could just not be making good contact from the legs to the pads.

Maybe is somekind a isolation issue, gnd not connected etc, and with your body you make the ground. If it is new, ask for a replacement in the store

Hi folks; thx for teh replies!

Finally got some time to attend to this matter, so it’s time for an update :sunglasses:

Well, even though it was a new board and even if I could maybe get a replacement,
I decided it would be too much of a hassle for me, if I went that way…

Long story short, after ‘refreshing’ a substantial amount of solder joints,
it finally worked, even though I gave my best trying to bend the board in
many directions [and not breaking it at the same time].

Not enough, just couldn’t stop yet. :mrgreen:
Remember I mentioned that mini-USB port, which was a little on the loose side?
A pair of needle-nose pliers did the trick.
Now, with the connector not wobbling anymore, projects can continue :sunglasses:

So long,