V1 Firmware upgrade

Hello all, so I recently acquired a V1 DSO nano and would like to upgrade it to the latest BenF firmware (3.64 I believe?) however I’m having a hell of a time upgrading it. I’m not sure which method I’m supposed to be using so I’ve tried both to no avail.

The DfuSe Demo program doesn’t show the nano in the device list when connected, it seems I need some kind of driver that I can’t seem to locate…

I also tried extracting the .hex files and copying them to the dso manually. I copied the app (it turned to .rdy) then the lib (which also turned to .rdy) but then when I restart it, it just boots the old firmware.

When it’s booting up it says my current firmware version is 3.04 if that matters. Any help is appreciated! Thanks

It looks like you have the earlier ver so you would need the dfu installer i will find the link amd post soon


So mine looks like a V1 but upgrades like a V3 with a virtual disk. I got it up to version 4.20 from here


Seems to be working fine but that damn purple data trace is still there, haha.

Hi forum chaps and chapesses…

I’ve been chasing my tail over this for a couple of days now and like the guy who won’t ask for directions or read a map, I’ve being trying to fix it myself…!

I was happiy using V3.26D on my V1, when in a rush of stupidity, I tried to upgrade to Ben’s LIB353. Copied across both files as instructed and… nada… No worries, I’ll load the original files back as I’m bound to find the on the web somewhere.

Well, I can’t and I’m royally screwed as the nearest I can get is a V4.20, that bounces a ‘Demo Only’ balloon around the screen… :neutral_face: :neutral_face: I have also tried V4 and V4.11 to no avail.

Can anybody please point me in the right direction to getting my V1 back to normality. I promise that I won’t tinker with it again (honest!)
Thanks in anticipation.

OK… What a great forum. 5 minutes searching and I found the V4.21 that has put my V1 back in the land of the living…

Thanks SeeedStudio…!

having the same problem here man. I’ve tried to revert to the orig fw but no good, it might’ve been an old version but it didn’t have the purple trace of death! Gonna try some dfu files on it now…good luck

Hi There you have 3 options

the 2 hex files
Original software up date 4.22

see my other messages on here G4VVQ