Uploading firmware to Rainbowduino v3.0

Having problems with uploading firmware to my Rainbowduino.

Using v3.0 so connected to my PC via USB.

From board i have selected : “Arduino Duemilanove w/ ATmega328”
however i have tried pretty much all of them ending in ATmega328.

From Port i have COM4 selected, I’m sure this is the correct Port as when i unplug the USB this option disappears.

When i click upload i get the following:
“Binary sketch size: 4134 bytes (of a 30720 byte maximum)
avrdude: stk500_getsync(): not in sync: resp=0x00”

The Rainbowduino itself has a green led which lights up when plugged it.
Upon upload there are 3 red LEDS next to the reset switch, 1 marked “RST” flashes 3 times very fast, followed by the LED marked “RX” flashing 3 times a bit slower.

The code I’m trying to upload is the example “PlasmaMatrix”.


  1. Can you upload firmware to the rainbowduino regardless of a matrix being plugged in?
  2. What position should the switch on the board be in? I think its marked one side USB and the other HOST, my guess is that one is to take commands from the PC and one is stand alone board?
  3. What am i doing wrong? :slight_smile:

Additional notes: I’m using a custom 8x8 led matrix ive put together. Could this be an issue at this stage, if not can we ignore this for now and just get examples uploaded first.

Thanks, Billy.

1.I can upload firmware to the rainbowduino regardless of a matrix being plugged in,I just try it.
2.Switch to the USB.
3.you can try to pressing the reset button on the arduino just before you clicked to upload my code onto it.(Try it without the matrix)

Thanks for the reply!

  1. Well that’s good to know.
    2 and 3. Tried uploading with the switch set to USB and still no luck. I hear you mention “the arduino” I’m not using my Arduino at all at the moment, this is purely uploading PC->Rainbowduino via usb.

So no progress so far.

Hi~ sorry to confuse u,
what i mean is before you are upload the code to the rainbowduino,you can try to pressing the reset button on the reainbowduino,and then upload the code.

Hey Tobe, tried this and no success. I actually have another Rainbowduino ordered and should receive it either today or tomorrow. Ill have a try with this one, if this one works I guess we can narrow the problem down to the other board, if it doesn’t; something else, Arduino IDE settings or maybe even the cable? Ill let you know how I get on when I receive it.

In the meantime, can you think of anything else I can be trying?

Regards, Billy.