Upload frustrations, triumphs, and questions w/ v328


Today I received my first Seeeduino - my first Arduino of any kind, for that matter. I eagerly rushed through the IDE and FTDI install to get things rolling. I was crushed to find that uploading did not work. :cry: Here are the details.

Windows XP SP3
Arduino IDE 017
Seeeduino V328
Only one COM port shows up, which I’ve selected.

Like so many other Arduino users, I received the dreaded:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

This originally happened when my first Blink upload took more than 20 seconds to complete. I wasn’t sure what to do so I hit the reset button… that was that. No other uploads were successful after that. I searched the net for resolution and found no recommendations that helped.

One common recommendation was to make sure you had the correct Board selected in the IDE. Ok, I have the 328 so I selected “Arduino Duemilanove or Nano w/ 328” – doesn’t work. :cry: (looking back, I was naive to think that the fancy name was tied to the chip number)

Ok, reviewing the details on the main product page I found this, “Its design is based on Diecimila scheme”. So I selected “Arduino Diecimila, Duemilanove, or Nano w/ 168” – doesn’t work. :cry:

There is no entry for Diecimila w/ 328 so what the heck - let’s try something else “… w/ 328”. I selected “LilyPad Arduino w/328” and whaddaya know – It WORKED!!! :smiley: but… why?!

Can anyone explain what I’m doing wrong or where I could have found this information?
Is there a reason why I shouldn’t interface the board as a LilyPad?

Thanks for reading,

Just a quick follow-up. I was delighted to successfully control servo position with a potentiometer input.

I’ve uploaded a dozen or more sketches and have not had any more trouble with “Lilypad Arduino w/ 328” chosen.


Hi Shawn,

Seeeduino v328 is burned the Arduino Duemilanove 328 bootloader.
Please select the “Arduino Duemilanove or Nano w/ATmega328” in the Arduino IDE menu.
If it is not work, Please try burn the Arduino Duemilanove 328 bootloader in the …arduino-0017\hardware\bootloaders\atmega ATmegaBOOT_168_atmega328.
How to burn bootloader without programmer:
geocities.jp/arduino_diecimi … ex_en.html


I received my seeeduino today and looks like it has the same problem. Tried on Windows and linux and both give the same error:

avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x00

I’ve tried all the usual stuff, manual/auto reset, different board options etc. Trying the Lilypad Arduino w/328 tip suggested above doesn’t seem to work either.

The board is powering up OK and L13 is constantly flashing. I get the occasional flashes on the TX and RX lights, but nothing sustained when trying to load a sketch.

Does this mean I need to reload the bootloader? If this is the case, can you provide any guidance on the wiring on the seeeduino?