Upgrade DSO201 Nano Firmware V3.21A


Today I’ve been struggling to update the DSO201 to BenF firmware 3.64…
That is: I’ve located two different Windows machines (I don’t have them at home). One Windows XP sp3 and one Windows 7 and then I installed DFuSe Demonstrator and tried to let it talk to my DSO201… no luck :frowning:

All kind of pupup windows show up stating that windows is installing all kind of drivers and devices. I can also see a new drive letter appearing (probably from the microSD drive which I had not inserted at the time).

Anyway: no way to trigger DFuSe to detect the USB port to upload the .dfu fules to…

I’ve removed the program, installed it again, installed different versions (3.0, 3.01, 3,02) rebooted the PC and the lot (everything anybody has written about how to do this)…

But I wonder…
… when I put my DSO201 in upgrade mode, it says “Please copy Hex or Bin file to the DFU virtual USB disk”.

Can it really be that simple? Do I only have to put a microSD card in an copy the “DSO BenF APP v3.64.dfu” and “DSO BenF LIB v3.53.dfu” files on it and than reboot???

Can anyone confirm this OR tell me what I can do further to get the Windows machine to see the DSO201 so I can use DFuSe to upgrade the firmware…

Thanks in advance!

Here I’am again.

Albeit, the brainwave to just copy the files to the virtual DFU USB drive did not work. Not as .dfu files and not as .bin files for that matter.

Copying the files to the microSD card does not work either (the DSO201 will not start with a microSD card inserted).

Is there anybody out there that can help me??

Thanks in advance!


This is what I find on the internet:

[code]Bit when I hold the down (-) button and turn it on it says:
“Serial:######## License:##########
Device Firmware Upgrade V3.21A
Please copy the Hex or Bin file to the DFU virtual USB disk”

Hmm, that’s really weird. I’ve never had that happen.

It goes to the firmware install mode. I just cant get the PC to stop thinking it is a hard drive. It wont accept the Dfuse driver.

You shouldn’t need an sd card.
also, did the dso nano go into the firmware install mode or just boot normally?

I also tried manually launching the Wizard through the Device Manager and navigating to the C:\Program Files\STMicroelectronics\Softw­are\DfuSe\Driver folder but it says “The specified location does not contain information about your hardware”
I Have the DSO201 and it does not have an SD card. DO I need that to install firmware?

Hey! I need help and I can seem to find any with google.
I can’t get my DSO to show up in Dfuse as device in the popup menu.
After I install Dfuse and then turn on my DSO while holding down the button to go into firmware mode, The DSO just shows up as a drive. I never get the New Hardware wizard.
I have tried 3 different PC’s. Any ideas?

This is exactly what hapens with my DSO201. It seems “they” have changed the upgrade process … but how???

Ok, this is what I found on the Seeedstudio Blog for upgrading the DSO QUAD:

So, also for the DSO201 NANO (V1) the upgrade process has changed.
The remaining question now is: How do I get the “.HEX”, “.ADR” and “.BIN” files for the upgrade to DSO BenF V3.64??

Can anyone please help me with this one?


Alf seems to have cracked the problem!!!

Board index » Tech Support » DSO nano

Page 5


Hi all,

I ma new to this, and have started to upgrade the DSO Nano firmware.

I have successfully copied the specified images into SD Card, but after reboot my DSO Nano gives the screen as attached in the image.

Please let me know how to make it work again.

Lalit Shah

Hi all,

Please help me to come out of this situation.

Lalit Shah

Hi all,

The initial screen when i apply for upgrade is as per below.

Here i am not able to connect the device in DFU mode, i just need to copy bin or hex file into the SD card.

The attached image will provide you the screen when i copied the files into the device.

Lalit Shah

Hi tormod,

Thanks for feedback.

I have one more Oscilloscope that works fine with DfuseDemo and i am able to upgrade that as well.

I have copy only lib files into the folder as suggested by you. But still not getting any progress with this Oscilloscope.

At power on still it displays the same screen.

Is there any way by which i can have a DFU mode support in this device?

Lalit Shah

hi all,

I have update the lib version to 3.13 and it successfully shows the same.

I am applying the app for the same version but not able to see the application version.

The same files works fine with the DFU mode upgrade process.

How to configure this device to work in dfu mode?

Lalit Shah


I have just received a SainSmart DSO201 Oscilloscope.

I just want to confirm it is compatible with BenF firmware before I try to upgrade…

currently running version DSO201+ APP v3.01

Just a little update. A positive one.

I went ahead and tried Alfs files for BenF 3.62 firmware and it worked perfectly.

This is on sainsmart DSO201 with bootloader v 3.22

BenF firmware is awesome, so much more usable than stock.

i already update the firmware to benf 3.64 with the alf hex files, but i can’t save wave in bmp and xml when i triy it says
sd err even if a formated a 1 gb micro sd with windows 7 to fat,
please help