Update problem - newbie question

Yes, I read the manual :wink:
My problem is:
I tried to upgrade the FPGA, so downloaded “FPGA261.zip”, connected my DSO203 to my Windows PC in upgrade mode without any problems, copied the file “*.ADR” to the device (like described in the wiki). After doing this, the storage in upgrade mode is no longer available (is connecting/disconnecting/connecting…); the wiki tells me “just delete all files” but I can’t access anymore.
Even rebooting/removing the battery didn’t change anything.
The normal operation is still possible, also access to the storage in normal operation mode is no problem.
Is there any way to reformat or reset the upgrade storage somehow?
Thanks a lot!

Did you miss the other file??

You start the DSO in upgrade mode
copy the CFG_FPGA.ADR file
copy the FPGA_V25.BIN file

Now, power off and on to start in normal mode

The upgrade guide states “you need to first copy the .ADR file , after the auto reset, the name changes to … And , then the .bin file, after the auto reset, the name changes to…”
So I copied the ADR file, and the DSR performed this auto reset, and now I’m lost.
Thanks a lot and regards

step-by-step (might help others too)

1 - Hold down Key1(Play/pause sign) and POWERON
This puts you in DFU mode and gives you a removable DFU disk on Windows platform
2 - Copy the .ADR file to the DFU disk
the DSO will disconnect and re-connect on USB
If you check the DFU disk directory, it will now show the .ADR file has now become .rdy or .not
if it is .rdy, your ADR file has been successfully read
.not means the file was not taken by dso
3 - If you got the .rdy confirmation in the previous step, copy the .BIN file to the DSO
Again you will find the DSO disconnects and reconnects
if you get the .RDY in the dfu disk, your file has been successfully copied.
if you get .not, the file is possibly bad
4 - Now POWEROFF the dso and POWERON
5 - Good to go now.!!

Maybe you missed some step??

no, I’m lost in step 2:
2 - Copy the .ADR file to the DFU disk
the DSO will disconnect and re-connect on USB
In my case:
The DSO disconnected and re-connect and disconnect and reconnect and disconnect and … and I was never able to check the DFU disk directory.

But I tried it using a Linux now, and was successfull:

  1. like described
    1a) mount -tvfat /dev/ /mnt/ (in my case: mount -tvfat /dev/sdd /mnt/usb)
  2. copy CFG_FPGA.ADR to /mnt/usb
    umount /mnt/usb (this forces a re-connect of the DSO, see /var/log/massages)
    mount -tvfat /dev/sdd /mnt/usb
    => it’s renamed to CFG_FPGA.SET
    copy V261FPGA.BIN to /mnt/usb/
    again umount/mount
    ==> the files are renamed to CFG_FPGA.USE and V261FPGA.RDY

Now I connect to Windows in DFU mode again, it’s recognized, I can copy a file to it, and the same game again: re-connect, disconnect, re-connect, disconnect ,…

Going back to Linux now I can connect like described above without any problems.
My Windows is a Windows 7 64bit; maybe the 64bit is the root cause?
From my side I’m fine now, thanks again!

Possibly Win7 is the culprit. My setup has XP. Glad to know your problem is solved.

Works for me on Windows 7 64bit

+1 to that. I’ve been through a few apps, sys and fpga’s and had no probs under Win7 64.