Unreliable XIAO?

I’m having some reliability issues with the XIAO. Just wondered if anyone else has experienced similar?

Have been able to program successfully a few times during development of a (simple) sketch, but then the XIAO stops working. Not detected under Windows until I reset it (quick double reset via the pads on the XIAO), at which point it appears as a drive letter and COM port again, but subsequent upload attempts always fail. After about 10s when uploading, the Arduino IDE eventually reports that there is no board at the designated COM port “No device found on COMx”. Sure enough, it is no longer there.

When I unplug the USB cable and plug it back in, I get the Windows “USB Device Not Recognized” balloon. Only the green power LED is on. Only the double-reset makes it appear again, and the yellow LED fades on and off, but cannot upload as before.

I’ve had this same behaviour happen on two different XIAOs now. Nothing special about the sketches, simple LED blinking and push-button detection. I’m working in an ESD-safe environment. Arduino IDE 1.8.13 under Windows 10, selected board Seeeduino XIAO.

Is this an experience others have had? Any suggestions for ways to fix? I will be trying the openocd bootloader write approach to try to fix.

Have to say I’m not happy with the XIAO as things stand.

We did receive a lot of feedback on XIAO’s upload issue.Most of them cannot be burned due to the sketch problem, so XIAO needs two consecutive reset. We will continue to track this issue.Look forward to finding out the real reason soon.

Thanks @Baozhu.

I was able to unbrick both XIAOs using SWD by re-writing bootloader. I will leave the SWD pins available on my development board so that I can recover from this situation again.

Yes, I purchased a pack of three of these little boards and at first was impressed! I uploaded a modified “blink” sketch to verify the setup and it went well. I could change the settings and reload the sketch and see the LED blink rate changes. After a couple iterations of this things went south. Now the board sits there with the latest “blink” settings and refuses to load. The compile goes fine but I get “An error occurred while uploading the sketch”. This is December now. I can’t believe this issue is still around?? The idea behind this XIAO module is great but I can’t justify putting it in any products or even prototypes with the unreliability issue. Your post was in early September. I don’t see any resolution posted yet anywhere. Am I missing something? I must be. How can the gadgets still be on the market? Hoping to hear some good news about this otherwise - moving on to other products.

@marty.chapman You will need to use SWD to reflash the bootloader. There is a helpful guide here. How to unbrick a dead xiao using raspberry pi [ GUIDE ][openocd]

1 Like

It ends up that it isn’t the bootloader needing reflashed in my case and the XIAO isn’t really “bricked”. By testing various scenarios I figured out that the XIAO doesn’t like my USB (3) HUB. It was interesting that if I powered down my laptop (not just a restart) the XIAO would then connect ok for 2 to 3 programming uploads in a row and then stop working (just hangs saying “uploading” in the IDE). Resetting the XIAO wouldn’t help, and exiting the IDE and restarting it wouldn’t help. If I take the HUB out of the picture and plug the XIAO directly into a USB on my laptop, it then programs fine every time! I’ll have to try another HUB to see if I see the same issue. That still doesn’t give me enough confidence to use the XIAO in a product yet. I intend to experiment with them more since they are a nice little drop-in module with a lot of libraries to support them. I design test systems and diagnostic units and by having them run on the Arduino IDE makes it easy for my clients to make changes without needing programming pods or returning devices, etc. Would certainly like to hear from anyone who has found this same issue and solved it or learned more about it. Thanks for your comments SnowyDog.

Same behaviour here except that I don’t use an USB hub.
I’m running IDE 1.8.13 on Ubuntu 20.04.1 with brand new Xiao’s . As Marty describes, initially all looks well and I was able to upload and test several simple sketches, even using serial monitor and serial plotter. And then it suddenly stops, the port setting in the IDE grey’s out and also the OS doesn’t see a USB connection any more.
Resets do not help, connecting to another laptop (both ubuntu and W10) do not give another picture.
I read the article on using RPI to unbrick a dead Xiao but I consider that a bridge too far.
I’ll continue to test, consider at the moment to install microPython and see how that behaves.
It’s a pity, it is a very nice device and absolutely perfect for my purpose. I sure hope somebody finds a solution!

EDIT: After publishing this comment I decided to give it one more try. Restarted laptop, made a new USB connection…nothing.
Out of pure frustration I did not do the reset once or twice but I hit it 6 or 7 times and, oh wonder, the orange led kept on, I saw the USB port again and could do another compile/upload… :+1: :+1:
I’ll continue testing and keep you informed

I’m using Win10x64 and have 3 XIAOS and 3 WIO Lite MG126s that are completely useless to me.

Yes I put these in the drawer in the fall because every SAMD21 based board I had eventually became completely unprogrammable. I want to like them but I hate them. I dug them out to see if there are any updates and I’m still wondering if I should toss them.

What’s the actual deal with accessing the XIAO in DFU mode or whatever it is so you can see the drive letter that everyone takes for granted? When I double tap the reset all I get is an incremented com port.

I’ve done all kinds of things including enabling test mode and disabling driver signing, I use a usbview utility to delete the drivers by vid/pid and then restart and then MAYBE i can program to the damn thing once.

So… I want to try circuitpython for the XIAO and none of these things create a drive letter.

I started with using the Arduino IDE then I learned Atmel Studio then I went to PlatformIO just trying to find any GDMF thing that could talk to these MF things.

Don’t let my tone seem like I’m frustrated at you. It’s just like every GDMF thing I try to do on any samd21 turns into a MF study in anger management.

Its May 2021 and I just received 2 Xiao and seeing same problems as everyone else.
Very frustrating as I had a project in mind, but as others have said the Xiao is just too unreliable to work with. Out of the bag I could see it as a com port but after attempting to upload a simple “Hello World” sketch - I received upload errors and now only green led on - no com port. Tried reset and yellow led lights but that’s it.
So back to the drawing board. Its odd that these problems have been around for some time and not resolved.