Unable to upload BOM file

I attached my BOM-file.



The Gerber file of my PCB uploads just fine - whenever I try to upload this BOM file, the popup “The system is now calculating the component cost.” remains displayed indefinitely (I tried waiting for a full hour - no luck).



Is something wrong with my BOM-file? My Gerber file? Would be great if someone could give some pointers so I can start figuring out why this is happening.
particle_BOM2.xlsx (10.1 KB)

Hi Lex,



Thanks for your message, did you get it to work? I’ve just tried uploading the BOM using Microsoft Edge and Chrome without problems, there is nothing wrong with the format. Could you try again? It could just be a poor internet connection.

No, I continue having this issue. Yesterday, it did go through and it required me to input purchase links for three components as they couldn’t find it.



However, besides that one time I continue to experience issues with uploading my BOM-file…it always remains stuck in that window for hours. It’s annoying as now I can’t make any adjustments or anything to my PCB, or spend hours trying it over and over.

That is very peculiar, I’ve just tried again and I’ve asked a few other colleagues to try and they didn’t have any issues. The IT team are also checking to see if they can find anything odd.



Could you let us know what browser you are using? Can you download the template and try uploading that?