Unable to update firmware


I have checked all the forum posts and no luck so far.

I have tried windows 7/8.1/10 using the firmware update guides. I have also tried with Linkit Assit Firmware update tool using .cfg file but I m stuck and this is annoyying.

Can someone please suggest a working method


Any “exact” problem?
The firmware updater halts, or does not even start the update process?
If you plug the rephone in, does the flash disk even appear?
Oh, and was the rephone on when you tried to update?

After 1 min, I get timeout error message.

I tried both in Mass storage mode and Switched on mode. I see the Modem and debug ports in Hardware manager when the board is on and connected to windows

When I suffered from timeout, I had to close the updater, pull the battery and usb cable out, reattach the battery, replug the rephone, ad start the firmware updater. It solved for me.

@dbealm I have tried what you suggested but no luck. Following is the log generated by update tool.

++++++++++++unlock the download…
*********************************Start Time : 17:58:20 **************************
New action to upload target binary.
b_newcomport = false --1
++++++++++++Could to downlaod and unlockit…
USB Insert27/02/2016 17:58:25

We have managed to update the firmware once. Never before and never since then.
Anyhow, this was our setup:

  1. Windows 10. It has never worked on Windows 7.
  2. The key item is that you ought to see a single USB device called “MTK USB Port” in the device manager. If you see none, while connected, or you see two (MTK USB Debug and MTK USB Modem) then you are not there yet.
  3. We have connected the module without battery first, and connected the battery only somewhat later, when the PC started the new device detection.
    Also please consult the Mediatek Assist 2502 Developer’s Guide at the Mediatek website. (Sorry I am still new user here and the forum engine prohibits me insert links here). Check chapter 4.1 and Figure 40. As you see, there is a state when the bootloader ought to emulate a single USB device.
    If you were able to update the firmware based on this vague description, I would appreciate if you could drop a note.

Thanks @molnarkaroly for your reply.

I got two rephone kits. I was able to update the firmware the first one without any issue on Windows 7.

For the second one, after several tries, I was able to update successfully using the following method on windows 7

  • Unplug the board from PC and disconnect the battery.
  • Plug the board to PC without any modules connected to the board and without sim card.
  • Open the firmwareupdater.exe
  • Connect battery
  • Power on the board and wait for green LED
  • Switch on board and press download button on FirmwareUpdate tool.
  • When FirmwareUpdate tool asks to reboot the board, Press and hold the on/off button on board to reboot while connected to PC. The bright green LED turns changes to dim red colour and you should see the download progress successfully

I hope someone will find a better way but this process is really annoying