Unable to flash PI CM4 on Dual Gig Ethernet Carrier Board

Hello everyone,
I have bought myself a “Raspyberry Pi CM4 1 Gig RAM 32Gig eMMc Flash” and a “Dual Gig Ethernet NIC Carrier Board”.
I had already installed my PI on my Carrier Board and my next step was to flash the eMMc storage for OpenWRT which I wanted to install. I followed seeeds instruction for flashing the stoarge, so I connected the “boot” and “ground” pins with a jumper cable and then the carrier board via USB-C to my computer. It turned on without any HDMI output and the green light not flashing as intended, but my computer did not register any kind of input. I then tested it with my laptop, but it resulted in the same.

I am relatively new to the whole topic of Raspberry PI, so I don’t know if I’m doing something very obviously wrong (like the 1 GIG RAM Version of the PI not being compatible) or if something on the carrier board or the PI is actually broken.

If any of you have an idea what might be wrong, I would very much appreciate a quick response.

Hello, when you connect GND and Boot and then use type C to connect to the computer, does the computer have any reaction? I think you can check the connection between CM4 and the carrier plate

Hi thanks for your answer,
no unfortunetly once I connect GND and Boot pin, there is absolutely zero output.
My computer doesn’t even recognize something connected (I checked in windows device management and disk manager), even though it’s delivering power to the pi.
If I don’t connect GND and Boot pin I get at least an HDMI output where the PI tries to boot.

On CM4, connecting the GND and Boot pins will turn the EMMC into USB storage, at this time there will be no HDMI output, it is worth noting that the GND and Boot pins need to be connected and kept before powering up, as well as the need to use the rpiboot tool before USB storage will appear

I don’t think I explained myself correctly there.
I get the HDMI output when not connecting the GND and Boot pin, as it should be. I mentioned this to express that the CM4 is probably mounted correctly to the carrier board. The issue is that once I connect the pins, the EMMC storage is not regcognized as a usb storage by my computer. It is in fact not regcognized by my computer in any way. If I run the rpiboot tool it just keeps searching for the storage forever.

Hi, I find a problem, if you connect GND and Boot pins, BCM2711 Boot devices will appear in the Windows device Manager on USB devices, have you tried replacing the type C cable?

Yeah I tried replacing the cable (I used three different USB-C cables). I also used a different USB port on my computer and since that didn’t work either I tried my laptop, which also didn’t work. I also looked up the windows device manager like you did, but the “BCM2711 Boot” device didn’t appear.
I think there might actually be something that doesn’t work on my carrier board. Judging from your screenshot, at least something should have connected to my computer, but nothing happend in the device manager while connecting.

According to your description, there is something wrong with your equipment

I think so too. I’ll contact my vendor and ask them to send me a new device.
Thank you, massive help!