Ultrasound Ranger not working on Raspbian


I am currently experimenting with a Grove Ultrasound Ranger connected to a GrovePi+ board attached to RaspberryPi 3B+. I have setup a software environment according instructions on this page: http://wiki.seeedstudio.com/Grove-Ultrasonic_Ranger/ and on GitHub https://github.com/Seeed-Studio/grove.py.

Unfortunately my sensor is still not returning any data instead of it I receive, while using the command “grove_ultrasonic_ranger 12” I receive only a text message: "Detecting distance… " and nothing happens no matter how long I wait (changing pin number has not solved it). While testing it with code exapmle from this GitHub page: <LINK_TEXT text=“https://github.com/Seeed-Studio/grove.p … /README.md”>https://github.com/Seeed-Studio/grove.py/blob/master/doc/README.md</LINK_TEXT> I receive only a stream of “TypeError” messages.

As an attachment I uploaded the log file obtained from the “all_tests.sh” Troubleeshooting script (log.rtf). What might be important is an error message saying that wiringPi has not been found, even though it is already installed.

Am I missing some crucial step in software/hardware setup, that is preventing sensor from working properly?

Thank you for your help



I tried to test my hardware with the Raspbian for Robots by Dexter Industries but scripts still sends back only the error message. The log from Troubleshooting tests is attached as log_rfr.rtf
log_rfr.rtf (6.43 KB)
log.rtf (11.9 KB)

Hi there,

You mixed GrovePi_Plus with Grove Base Hat for Raspberry Pi. As you use the Grovepi+, you have to follow up <LINK_TEXT text=“http://wiki.seeedstudio.com/Grove-Ultra … ovepi_plus”>http://wiki.seeedstudio.com/Grove-Ultrasonic_Ranger/#play-with-raspberry-pi-with-grovepi_plus</LINK_TEXT>. thanks.

Thank you for your answer.

I have followed instructions on the webpage that you linked for me.

Unfortunately it doesn’t work.

At “Step 1. Follow Setting Software to configure the development environment.” I got an error message when I execute command:

</s> sudo ./install.sh<e>

This error message is displayed below.

</s><i> </i>./install.sh: line 11: /home/pi/Dexter/lib/Dexter/script_tools/functions_library.sh: No such file or directory Special thanks to Joe Sanford at Tufts University. This script was derived from his work. Thank you Joe! ./install.sh: line 38: feedback: command not found I2C-dev already present i2c-bcm2708 added spi-dev added ./install.sh: line 58: feedback: command not found The user `pi' is already a member of `i2c'. ./install.sh: line 76: feedback: command not found ./install.sh: line 77: /home/pi/Dexter/lib/Dexter/script_tools/install_avrdude.sh: No such file or directory ./install.sh: line 78: create_avrdude_folder: command not found ./install.sh: line 79: install_avrdude: command not found done with AVRDUDE for the GrovePi <e>

I have copy pasted all the commands in the instruction. It was done on a fresh Raspbian install.

Hi kubakrno,

The root cause is raspberry pi not setting up well to work with grovepi+. please follow below instructions. thanks.

Step 1. In the command line, type the following commands to setup your Raspberry Pi software to work with the GrovePi+.

sudo curl -kL dexterindustries.com/update_grovepi | bash

sudo reboot

Step 2. Git clone the Github repository.

cd ~

git clone https://github.com/DexterInd/GrovePi.git

Step 3. Excute below commands to use the ultrasonic_ranger to meansure the distance.

cd ~/GrovePi/Software/Python

python grove_ultrasonic.py

Step 4. We will see the distance display on terminal as below.

pi@raspberrypi:~/GrovePi/Software/Python $ python grove_ultrasonic.py












I have tried your instructions but the result stays the same. command
</s>python grove_ultrasonic.py<e>
delivers only a column of error messages like this:
</s>Error Error Error Error Error Error Error Error Error Error Error Error Error Error Error Error Error Error Error<e>
They keep coming until I terminate the command with “ctrl+c”.

As an attachment I send the log obtained from troubleshooting tests.

Thank you for your assistance.

Best wishes,

log_20190204.rtf (6.58 KB)