UEFI HTTP Boot with proxyDHCP

I’m trying to network boot the odyssey board using UEFI HTTP Boot, my ISP DHCP server and a proxyDHCP server.

In the following screenshot, you can see the DHCP Offer from my proxyDHCP ( and the DHCP Offer from the ISP DHCP server (

Unfortunately, the Odyssey board seems to assign the IP address given by the ISP DHCP Server, BUT immediately returns to the boot menu and ignores the proxyDHCP DHCP Offer, thus, failing to boot. Here’s a video of it trying to boot:

Please note that this same setup works fine with a Raspberry Pi 4 (using the GitHub - pftf/RPi4: Raspberry Pi 4 UEFI Firmware Images firmware).

Please note that the equivalent of DHCP+proxyDHCP works fine when I use PXE TFTP Boot instead of UEFI HTTP Boot. Also note that the equivalent of DHCP (without proxyDHCP) and HTTP Boot also works fine. So it seems this only stops working when there is a proxyDHCP sending another DHCP Offer.

Do you known why this happens?

Can you help me troubleshoot/fix this?

Thank You!


Could you please update the BIOS and EC firmware to the latest versions?

And let me know the result.

Thank you.

Sorry, I forgot to mention that I’m using the latest firmwares. Any other suggestions?

Hello @rgl,

Could you do a BIOS reset, please?

Follow the steps below:

  1. Turn off X86
  2. Remove CMOS battery (yellow color)
  3. Wait for a couple of minutes
  4. Install CMOS battery
  5. Turn on X86

And then try again?

Thank you.

@lakshan it worked! thank you!

Any idea why one needs to do that? As a workaround, maybe the upgrade bios documentation should say that we must remove the battery? or even better, would a “Reset to Defaults” also work?

BTW, while trying this out, I found another problem, when the HTTP Boot fails (for example, when the HTTP Boot server returns a 404) and we retry it from the bios, it does not work until we reset the board and go into the bios HTTP Boot menu again.

Hello @rgl,

That’s great! Sometimes certain board-related problems can be solved by simply resetting the BIOS.

For the next question, what do you mean reset the board? hard power off from button and power back on?

The problem with resetting the bios is that we loose all the settings and forces us to reconfigure everything again. Even more so, because there is no way, that am I aware of, to save/load the settings from a plain text file. Which makes the whole experience quite time consuming.

By reset, I mean, reset the system, like pressing the ctrl+alt+delete keys.

Hello @rgl,

But you do not need to reset the BIOS always after powering off to fix your issue right? One BIOS reset fixed the issue right?

Yes, one reset of the bios works. For now on I’ll always do that after each firmware upgrade.

But we should not have to reset it in the first place. The update process should try its best for upgrading the settings or explicitly fail the upgrade process otherwise.