UART problem on x86j4105

Hi, it’s possible that after update the latest firmware for bios/ec the uart on 40 pins header stop working?
I have tryed all, but it’s died, i also tryed to connect tx/rx and send thru minicom on /dev/ttyS4 but nothing happens.

Please help me

Have you enable the uart function in BIOS setting?

Yes sure, i enabled uart from bios but pins still act like gpio. I also tried to downgrade the firmware but the situation remains the same…i don’t know what to try anymore, the uart doesn’t work.


@Emanuele_Carozzo Confirmed your board is J4105 but not 4125? Have you also upgrade the EC firmware?

Hello, you can try to restore the BIOS factory Settings and reboot

Yes, I confirm that is a j4105 with latest firmware (SD-BS-CJ41G-300-101-K), i have also upgraded EC with the latest firmware but I have had a problem, the latest version of the downloadable EC firmware (SD-EC-CJ41G-M-101-R) from the site is without the EFI folder inside and therefore does not boot, so I copied it from the previous one but I don’t think that can be the problem.

Unfortunately i have already tried, finished the bios update, as the instructions also indicate I disconnected the bios battery and reset to factory settings.

@Emanuele_Carozzo can you share me the bios setting? I have test the /dev/ttyS4 on my side, it’s work OK for me.

The BIOS setting on my devices like the following.

And the hard ware connection like the following.