total fail on firmware upgrade for both OSX and XP

I know I must be doing something DUMB. Please point it out to me!

I have tried both the 3.0 and 3.0.1 on XP. On machine one, st demo fails to run. cRASH

On XP system 2. it never recognizes the dso nano.

Michael-Pechners-MacBook-Air:dfuse-dfu-util mpechner$ ./src/dfu-util --dfuse default -a 0 -D ~/Downloads/DSO\ BenF\ Firmware\ v3.61/DSO\ BenF\ LIB\ v3.52.dfu dfu-util - © 2005-2008 by Weston Schmidt, Harald Welte and OpenMoko Inc.
© 2010 Tormod Volden (experimental DfuSe support)
This program is Free Software and has ABSOLUTELY NO WARRANTY

dfu-util does currently only support DFU version 1.0

No DFU capable USB device found

The both my DSO nano and dso nano ver 2 are “DS0201 Device Firmware Upgrade Ver 2.0”

I know I have upgraded software before. This time nothing is working.

I prefer if someone has working OSX instructions.

It was the (&(()&^@#$%^ usb cable. Used a different cable and all worked perfectly on XP.
Hours lost due to some cheap cable that worked for other devices.

Upgraded to latest BenF firmware.